Opened 8 months ago

Closed 8 months ago

#33026 closed defect (duplicate)

Problem using obfs4 on Android arm64: executable's TLS segment is underaligned

Reported by: uhdv Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: sisbell Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi,

I can't connect with latest Android Tor Browser

Without hidden relay it's like that :

- updating settings in Tor service
- updating torrc custom configuration...
- success.
- checking binary version: 0.4.1.5-rc-openssl1.0.2p
- Orbot is starting…
- Connecting to control port: 37805
- SUCCESS connected to Tor control port.
- SUCCESS - authenticated tor control port.
- Took ownership of tor control port.
- adding control port event handler
- SUCCESS added control port event handler
- NOTICE: Opening Socks listener on 127.0.0.1:9150 
- NOTICE: Opened Socks listener on 127.0.0.1:9150 
- NOTICE: Opening DNS listener on 127.0.0.1:5400 
- NOTICE: Opened DNS listener on 127.0.0.1:5400 
- NOTICE: Opening Transparent pf/netfilter listener on 127.0.0.1:9140 
- NOTICE: Opened Transparent pf/netfilter listener on 127.0.0.1:9140 
- NOTICE: Opening HTTP tunnel listener on 127.0.0.1:8218 
- NOTICE: Opened HTTP tunnel listener on 127.0.0.1:8218 
- NOTICE: Bootstrapped 5% (conn): Connecting to a relay 
- Starting Tor client… complete.
- NOTICE: Bootstrapped 10% (conn_done): Connected to a relay 

And with obfs4 hidden relay it's like that :

- TorService is shutting down
- Using control port to shutdown Tor
- NOTICE: Closing no-longer-configured HTTP tunnel listener on 127.0.0.1:8218 
- NOTICE: Closing no-longer-configured Socks listener on 127.0.0.1:9150 
- NOTICE: Closing no-longer-configured DNS listener on 127.0.0.1:5400 
- NOTICE: Closing no-longer-configured Transparent pf/netfilter listener on 127.0.0.1:9140 
- NOTICE: DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections. 
- NOTICE: Delaying directory fetches: DisableNetwork is set. 
- sending HALT signal to Tor process
- Orbot is deactivated
- updating settings in Tor service
- updating torrc custom configuration...
- success.
- checking binary version: 0.4.1.5-rc-openssl1.0.2p
- Orbot is starting…
- Connecting to control port: 42415
- SUCCESS connected to Tor control port.
- SUCCESS - authenticated tor control port.
- Took ownership of tor control port.
- adding control port event handler
- SUCCESS added control port event handler
- NOTICE: Opening Socks listener on 127.0.0.1:9150 
- NOTICE: Opened Socks listener on 127.0.0.1:9150 
- NOTICE: Opening DNS listener on 127.0.0.1:5400 
- NOTICE: Opened DNS listener on 127.0.0.1:5400 
- NOTICE: Opening Transparent pf/netfilter listener on 127.0.0.1:9140 
- NOTICE: Opened Transparent pf/netfilter listener on 127.0.0.1:9140 
- NOTICE: Opening HTTP tunnel listener on 127.0.0.1:8218 
- NOTICE: Opened HTTP tunnel listener on 127.0.0.1:8218 
- Starting Tor client… complete.
- WARN: Managed proxy at '/data/app/org.torproject.torbrowser-muJdMAge2O52aHgePxNzIw==/lib/arm64/libObfs4proxy.so' reported: error: "/data/app/org.torproject.torbrowser-muJdMAge2O52aHgePxNzIw==/lib/arm64/libObfs4proxy.so": executable's TLS segment is underaligned: alignment is 8, needs to be at least 64 for ARM64 Bionic 
- WARN: Pluggable Transport process terminated with status code 6 
- No network connectivity. Putting Tor to sleep…
- NOTICE: Closing no-longer-configured HTTP tunnel listener on 127.0.0.1:8218 
- NOTICE: Closing no-longer-configured Socks listener on 127.0.0.1:9150 
- NOTICE: Closing no-longer-configured DNS listener on 127.0.0.1:5400 
- NOTICE: Closing no-longer-configured Transparent pf/netfilter listener on 127.0.0.1:9140 
- NOTICE: DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections. 
- Network connectivity is good. Waking Tor up…
- NOTICE: Opening Socks listener on 127.0.0.1:9150 
- NOTICE: Opened Socks listener on 127.0.0.1:9150 
- NOTICE: Opening DNS listener on 127.0.0.1:5400 
- NOTICE: Opened DNS listener on 127.0.0.1:5400 
- NOTICE: Opening Transparent pf/netfilter listener on 127.0.0.1:9140 
- NOTICE: Opened Transparent pf/netfilter listener on 127.0.0.1:9140 
- NOTICE: Opening HTTP tunnel listener on 127.0.0.1:8218 
- NOTICE: Opened HTTP tunnel listener on 127.0.0.1:8218 
- WARN: Managed proxy at '/data/app/org.torproject.torbrowser-muJdMAge2O52aHgePxNzIw==/lib/arm64/libObfs4proxy.so' reported: error: "/data/app/org.torproject.torbrowser-muJdMAge2O52aHgePxNzIw==/lib/arm64/libObfs4proxy.so": executable's TLS segment is underaligned: alignment is 8, needs to be at least 64 for ARM64 Bionic  
- WARN: Pluggable Transport process terminated with status code 6 

Child Tickets

Change History (5)

comment:1 Changed 8 months ago by gk

Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team

comment:2 Changed 8 months ago by boklm

Cc: sisbell added
Status: newneeds_information
Summary: Filtered networkProblem using obfs4 on Android arm64: executable's TLS segment is underaligned

So it seems to be an issue running obfs4:

- WARN: Managed proxy at '/data/app/org.torproject.torbrowser-muJdMAge2O52aHgePxNzIw==/lib/arm64/libObfs4proxy.so' reported: error: "/data/app/org.torproject.torbrowser-muJdMAge2O52aHgePxNzIw==/lib/arm64/libObfs4proxy.so": executable's TLS segment is underaligned: alignment is 8, needs to be at least 64 for ARM64 Bionic  

Which Android version are you using?

comment:3 Changed 8 months ago by uhdv

@boklm

10

comment:5 Changed 8 months ago by boklm

Resolution: duplicate
Status: needs_informationclosed

@uhdv: so this should be fixed in the alpha version.

Closing this as duplicate of #32303.

Note: See TracTickets for help on using tickets.