Opened 8 months ago

Closed 7 months ago

#33089 closed enhancement (duplicate)

Add DuckDuckGo hidden service search engine to Tor Browser

Reported by: David_Hedlund Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I think DuckDuckGo hidden service (https://3g2upl4pq6kufc4m.onion/) should be the default search engine instead of https://duckduckgo.com/. The former search engine uses Tor unlike the latter.

Please leave feedback.

Child Tickets

Change History (4)

comment:1 Changed 8 months ago by David_Hedlund

Related: Change the default search engine in TBB - https://trac.torproject.org/projects/tor/ticket/4902

comment:2 Changed 8 months ago by cypherpunks

Yes, the DuckDuckGo hidden service is one of the best example, how useful and good onion services can be used for.

In a "tor browser" a user expects onion routing where possible. Please make use of it where available for most privacy possible. always safe rare exit traffic bandwidth from exit nodes.

comment:3 Changed 7 months ago by alwayslivid

I am currently working on this, but the domain https://ac.duckduckgo.com (suggestion provider) does not have a secret service itself.

Should the suggestion link be kept the way it is (not protected by Tor, which kind of effectively defeats the whole purpose), or should it be just removed altogether?

comment:4 Changed 7 months ago by pili

Resolution: duplicate
Status: newclosed

Before we make this change we should probably coordinate with DDG to ensure that their onion service would be able to cope with this change.

This ticket is also a duplicate of #21483

Note: See TracTickets for help on using tickets.