Opened 8 years ago

Closed 8 years ago

#3320 closed defect (fixed)

Can't apply changes to torrc when Tor haven't finished bootstrapping

Reported by: agnieszkaMD Owned by: chiiph
Priority: Medium Milestone:
Component: Archived/Vidalia Version: Vidalia: 0.3.0-alpha
Severity: Keywords: settings
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Defect reproduction steps:

  1. In torrc file add two lines - ExitNodes 1.1.1.1 and StrictNodes 1, or whatever will make connection to Tor network impossible.
  1. Restart Tor.
  1. Now Tor will constantly try to make a valid circuit and if you try to remove those 2 lines (using Vidalia GUI) it won't affect.

Possible solutions:

In TorrcDialog.cpp there's plenty of tc->isConnected(). Maybe it isn't necessary to be connected to save a torrc file? Also, isConnected() method seems to be indicating a fully established circuit, not only control socket connected to Tor.

Child Tickets

Change History (3)

comment:1 Changed 8 years ago by agnieszkaMD

Version: Vidalia: 0.2.12Vidalia: 0.3.0-alpha

It works the same in Vidalia 0.3.0-alpha.

comment:2 Changed 8 years ago by chiiph

Summary: Can't apply changes to torrc when Tor is not connectedCan't apply changes to torrc when Tor haven't finished bootstrapping

Yes, if you want to edit the torrc file within Vidalia, you'll need to be connected to Tor, because it works by giving control commands, not actually changing the file.

So, what I should look up in here is how to be able to change torrc while connected but not fully bootstrapped.

comment:3 Changed 8 years ago by chiiph

Keywords: settings added
Resolution: fixed
Status: newclosed

The new settings handling allows the user to do this. I'm considering this done.

Note: See TracTickets for help on using tickets.