Opened 9 days ago

Closed 6 days ago

#33200 closed task (fixed)

Reproducibility issue with bookmarks.html on macOS

Reported by: boklm Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-rbm, TorBrowserTeam202002R
Cc: sysrqb Actual Points: .2
Parent ID: Points:
Reviewer: Sponsor:

Description

When building Tor Browser 9.0.5, sysrqb and I got different osx64 bundles.

After comparing the two, the only different files are Tor Browser.app/Contents/Resources/browser/omni.ja. And comparing the two omni.ja, the difference is:

 --rw-rw-r--  3.0 unx     3863 t- defN 00-Jan-01 00:00 chrome/en-US/locale/browser/bookmarks.html
 +-rw-r--r--  3.0 unx     3863 t- defN 00-Jan-01 00:00 chrome/en-US/locale/browser/bookmarks.html

All the other files inside omni.ja have -rw------- as permission.

Child Tickets

Change History (4)

comment:1 Changed 9 days ago by boklm

Keywords: TorBrowserTeam202002R added
Status: newneeds_review

Maybe this is caused by different default umask? Although in var/set_default_env we reset it.

Default umask on my build machine is 0022.

I think this patch should fix the issue:
https://gitweb.torproject.org/user/boklm/tor-browser-build.git/commit/?h=bug_33200&id=aa1b470837799f7653135aad40b6365fb9220d0b

And the patch backported on maint-9.0:
https://gitweb.torproject.org/user/boklm/tor-browser-build.git/commit/?h=bug_33200-maint-9.0&id=f4b95bbd88087547c8c678d2302aeaa1728d2435

comment:3 Changed 8 days ago by boklm

Actual Points: .2

comment:4 Changed 6 days ago by sysrqb

Resolution: fixed
Status: needs_reviewclosed

Thanks! I merged this onto maint-9.0 as commit 16c72c7040e51364f497ec2ed8a597b6874d080d and onto master as commit 241e805dbbefcb0860bf32a38b63fcd7edf71a68.

Note: See TracTickets for help on using tickets.