Opened 8 days ago

Last modified 7 days ago

#33219 needs_information defect

Tor in China (Android) stops at 5%

Reported by: TiC Owned by:
Priority: Medium Milestone:
Component: Circumvention/Censorship analysis Version:
Severity: Normal Keywords: cn
Cc: dcf Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by dcf)


I am currently in China and since yesterday morning I cannot connect my tor browser on my phone unless I use another VPN service (which is very slow, so I would like to not use it). It is always stopping at 5%, I changed from mobile data to wifi, both does not work. I guess this is coincidence, but the problem occurred after I had tor opened while playing the Chinese PUBG (吃鸡).


- Einstellungen im Tor-Dienst werden aktualisiert /updating Tor applications 
- updating torrc custom configuration...
- success.
- checking binary version:
- Orbot startet …
- Connecting to control port: 44003
- SUCCESS connected to Tor control port.
- SUCCESS - authenticated tor control port.
- Took ownership of tor control port.
- adding control port event handler
- SUCCESS added control port event handler
- NOTICE: Opening Socks listener on 
- NOTICE: Opened Socks listener on 
- NOTICE: Opening DNS listener on 
- NOTICE: Opened DNS listener on 
- NOTICE: Opening Transparent pf/netfilter listener on 
- NOTICE: Opened Transparent pf/netfilter listener on 
- NOTICE: Opening HTTP tunnel listener on 
- NOTICE: Opened HTTP tunnel listener on 
- Tor-Programm wird gestartet … abgeschlossen. /Tor program gets started - finished
- NOTICE: Bootstrapped 5% (conn): Connecting to a relay 
- Netzwerkverbindung ist vorhanden. Tor wird aktiviert … /network connection available. Tor will be activated... 
- NOTICE: Your system clock just jumped 134 seconds forward; assuming established circuits no longer work.

Child Tickets

Change History (3)

comment:1 Changed 8 days ago by nickm

Component: - Select a componentCircumvention

comment:2 Changed 7 days ago by dcf

Cc: dcf added
Component: CircumventionCircumvention/Censorship analysis
Description: modified (diff)
Keywords: cn added; Tor-Browser 9.0.4 removed
Status: newneeds_information

Tor isn't expected to work in China without a bridge because of GFW censorship. But if it was working for you recently and then stopped working, the cause might be something other than censorship. The main clue I see is Your system clock just jumped 134 seconds forward. The first thing you should do is make sure your system clock is set correctly. An incorrect system clock can cause Tor to fail early in the bootstrap process like that.

comment:3 Changed 7 days ago by TiC

Thank you for the information, I just checked the issue with the system clock, but that should be alright. As far as I know the log was caused by my autoscreenlock of the phone. This cut the connection. I also tried several bridges, but they only work on my laptop, not on the phone. I used meek-azure as preset bridge, but I have down and uploadrates of 0-15 kbps.
A few days ago I had down and uploadrates of about 250 kbps, I don't know what happened at that morning, but since then nothing worked anymore.
For the requested bridges, they always stopped at 10%, no failure, but no loading at all. I tried for 5min, but it still didn't connect.

Note: See TracTickets for help on using tickets.