Opened 6 months ago

Closed 3 months ago

Last modified 3 months ago

#33267 closed task (duplicate)

Prop 313: 8.1. Test IPv6 Relay Consensus Counts using Chutney

Reported by: teor Owned by: teor
Priority: Medium Milestone: Tor: 0.4.4.x-final
Component: Core Tor/Chutney Version:
Severity: Normal Keywords: prop313, ipv6
Cc: teor Actual Points:
Parent ID: #33268 Points: 0.5
Reviewer: Sponsor:

Description

Test the IPv6 relay count script in proposal 313, using chutney networks.

Since chutney creates a limited number of relays, we also need to test these changes on consensuses from the public tor network. So we shouldn't spend much time testing the script with chutney.

See proposal 313, section 8.1, chutney tests part:
https://gitweb.torproject.org/torspec.git/tree/proposals/313-relay-ipv6-stats.txt#n337

Child Tickets

Change History (2)

comment:1 Changed 3 months ago by teor

Parent ID: #33050#33268
Resolution: duplicate
Status: assignedclosed

This ticket is a duplicate of #33268. If we find it useful to use chutney, let's do it in that ticket.

comment:2 Changed 3 months ago by teor

Sponsor: Sponsor55-must
Note: See TracTickets for help on using tickets.