Opened 8 months ago

Closed 5 months ago

#33295 closed task (fixed)

Install Python 3-related packages on polyanthum

Reported by: phw Owned by: tpa
Priority: Medium Milestone:
Component: Internal Services/Tor Sysadmin Team Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The anti-censorship team is currently porting BridgeDB to Python 3 and we need a bunch of new packages to make this happen.

Can you please install libpython3.7-dev on polyanthum?

Once this is done, I suggest leaving this ticket open because we're probably going to need more packages installed.

Child Tickets

Change History (3)

comment:1 Changed 8 months ago by anarcat

Status: newneeds_information

i added the python3-dev package which transitively depends on the requested package, without having to hardcode a python minor version (3.7) in the dependency.

let me know if you need anything else.

comment:2 Changed 8 months ago by anarcat

oh and before you go crazy installing random packages from pypi in a venv, please do check if they are available in debian packages and ask for them here. :) of course feel free to install them from pypi *first* but it would be nice if we could keep those deps to a minimum and rely on our (soon to be automatic) debian package upgrades to keep those packages up to date...

comment:3 Changed 5 months ago by anarcat

Resolution: fixed
Status: needs_informationclosed

i'll assume this is done.

Note: See TracTickets for help on using tickets.