Opened 6 months ago

Closed 5 months ago

Last modified 5 months ago

#33379 closed enhancement (fixed)

Make chutney wait for all relays in the consensus before verifying

Reported by: teor Owned by: teor
Priority: Medium Milestone:
Component: Core Tor/Chutney Version:
Severity: Normal Keywords: ipv6, prop311, network-team-roadmap-2020Q1
Cc: teor Actual Points: 2.5
Parent ID: #33050 Points: 0.5
Reviewer: ahf Sponsor: Sponsor55-must

Description

As part of #33232, we want chutney to check that all relays are in the consensus, then verify.

Child Tickets

TicketTypeStatusOwnerSummary
#33597defectclosedTravis: Revert to basic-min for Tor 0.3.5

Change History (10)

comment:1 Changed 6 months ago by teor

Actual Points: 0.5
Status: assignedneeds_revision

I've done some work on this ticket, and it's almost complete.

It was a bit bigger than I thought, because I forgot about bridges.

I also forgot that bridges will have their own descriptor in their cached-descriptors file (as well as the bridge authority, and bridge clients). So I'll have to fix that up.

comment:2 Changed 5 months ago by teor

Here is my work-in-progress branch, it works for about half the current chutney networks:

comment:3 Changed 5 months ago by teor

Actual Points: 0.52
Reviewer: nickmahf
Status: needs_revisionneeds_review

I spoke with Alex today, and he's happy to review these chutney changes.

Here's my draft PR:

It passes tor's make test-network-all locally, but chutney's CI is still running. There might be some issues with 0.3.5, like there were in #33378.

comment:4 Changed 5 months ago by teor

Status: needs_reviewneeds_revision

comment:5 Changed 5 months ago by teor

Status: needs_revisionneeds_review

I have tried adjusting the authority/exit mix in the standard networks, to make 0.3.5 more stable.

comment:6 Changed 5 months ago by teor

So I think I've finally fixed the 0.3.5 issue, and it's ready for review.

Here's what was happening:

  • 0.3.5 was slow to download microdescriptors, and the immediate, rapid SOCKS connections would put it in an unusable state until some existing microdescs expired
  • 0.4.1 and later have a fix for this issue
  • a short wait before the SOCKS connection also fixes this issue
  • checking for microdescs in #33428 will probably also fix this issue

CI is still running, and I'm still running local tests on master and 0.3.5.

Here's my PR:

comment:7 Changed 5 months ago by teor

Actual Points: 22.5

comment:8 Changed 5 months ago by ahf

Status: needs_reviewmerge_ready

This good stuff, Teor. I've left some small comments and nitpicks in the PR, but they are NOT blocking a merge. I think they can all be done in follow up PR's if we think it's worth it. I think this changes makes Chutney better.

I only tried it out locally with master and the 0.3.5 from my distro.

comment:9 Changed 5 months ago by teor

Parent ID: #33232#33050
Resolution: fixed
Status: merge_readyclosed

Merged #33583 to chutney master.

comment:10 Changed 5 months ago by gaba

Keywords: network-team-roadmap-2020Q1 added

Add all the tickets from sponsor 55 that are done and being worked on to the keyword #network-team-roadmap-2020Q1 so I can look at them in the wiki page...

Note: See TracTickets for help on using tickets.