Opened 3 months ago

Closed 4 weeks ago

Last modified 4 weeks ago

#33407 closed defect (duplicate)

Make chutney bridge authorities publish bridges in their networkstatus-bridges

Reported by: teor Owned by:
Priority: Medium Milestone: Tor: 0.4.4.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: ipv6, prop311, tor-bridge, chutney, outreachy-ipv6
Cc: teor Actual Points:
Parent ID: #33581 Points: 1
Reviewer: Sponsor:

Description (last modified by teor)

This issue depends on the tor bridge descriptor upload fix in #33582, or robust reachability self-tests in #33222.

Chutney bridge authorities don't have any bridges in their networkstatus-bridges. That's a problem, because we want to check networkstatus-bridges for the reachability checks in #33232.

Once bridges upload their descriptors, we can make chutney check the bridge authority's networkstatus-bridges for bridge nicknames (this ticket).

We can only do the networkstatus-bridges check on tor versions with the #33222 or #33582 fixes. So we'll need to check for:

  • the next tor 0.4.4-alpha version, or
  • an environmental variable that enables these tests.

We don't have to do these fixes, because it should be enough to test relay reachability. But we would risk breaking bridge reachability tests, and not knowing about it until after a release.

Child Tickets

Change History (14)

comment:1 Changed 3 months ago by arma

Can you give us some hints about what is going wrong? That is, why the bridge authority in Chutney doesn't have any bridges in its networkstatus-bridges file?

For example, are bridges publishing to it?

The "fix bugs in" options are very broad and vague, so it is hard to pick from them yet. :)

comment:2 in reply to:  1 Changed 3 months ago by teor

Replying to arma:

Can you give us some hints about what is going wrong? That is, why the bridge authority in Chutney doesn't have any bridges in its networkstatus-bridges file?

For example, are bridges publishing to it?

The "fix bugs in" options are very broad and vague, so it is hard to pick from them yet. :)

I haven't done any analysis yet, I've just noticed the issue while implementing #33378 and #33379.

Once those tickets are implemented, chutney will tell me which nodes have other nodes descriptors.

comment:3 Changed 3 months ago by teor

One thing I can tell you is that chutney bridges *have* descriptors. Otherwise chutney bridge clients wouldn't be able to make any connections.

comment:4 Changed 3 months ago by teor

Summary: Chutney bridge authorities have an empty networkstatus-bridgesMake chutney bridge authorities publish bridges in their networkstatus-bridges

comment:5 Changed 3 months ago by teor

Here are the most likely possibilities:

  • Chutney bridges don't publish their descriptors to the bridge authority
    • Chutney bridges don't bootstrap
    • AssumeReachable doesn't work on bridges
    • There's something wrong with the syntax of the generated AlternateBridgeAuthority lines
    • There's some code that delays bridge descriptor posts, and TestingTorNetwork / chutney doesn't change it, or that change doesn't apply to the bridge authority
  • The bridge authority has the descriptors, but it doesn't publish them in networkstatus-bridges
    • AssumeReachable doesn't work on bridge authorities
    • There's some code that delays bridge publication (like TestingAuthDirTimeToLearnReachability), and TestingTorNetwork / chutney doesn't change it, or that change doesn't apply to the bridge authority

comment:6 Changed 3 months ago by teor

Keywords: outreachy-ipv6 added

comment:7 Changed 3 months ago by teor

Parent ID: #33232#33050

comment:8 Changed 2 months ago by teor

Description: modified (diff)

Currently blocked by Tor's #33582 and #33408.

comment:9 Changed 4 weeks ago by teor

Description: modified (diff)

Here's a clearer explanation:

Currently blocked by a tor bridge bootstrap / descriptor upload race condition, see #33582.

Chutney may need to check for this tor bug fix. One way to do that is to modify the tor version EXTRA_INFO so it is sortable, see #33408.

comment:10 Changed 4 weeks ago by teor

Description: modified (diff)

comment:11 Changed 4 weeks ago by teor

Description: modified (diff)

Instead of this fix, we can make chutney check tor's logs for reachability self-test successes. See #34037.

comment:12 Changed 4 weeks ago by teor

Parent ID: #33050#33581

comment:13 Changed 4 weeks ago by teor

Description: modified (diff)
Resolution: duplicate
Status: newclosed

This is now a duplicate of #33581. I don't think there's any issue with the bridge authority or chutney, it's probably just a tor bug.

comment:14 Changed 4 weeks ago by teor

Sponsor: Sponsor55-can
Note: See TracTickets for help on using tickets.