Opened 8 months ago

Closed 6 months ago

#33465 closed defect (duplicate)

On Android, system locale is leaked in http headers

Reported by: boklm Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-mobile, tbb-fingerprinting, TorBrowserTeam202004
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

According to a user on the blog, system locale is being leaked in http headers:
https://blog.torproject.org/comment/286880#comment-286880

This should have been fixed by #26018. I think we should check if this fix is still working.

Child Tickets

Change History (5)

comment:1 Changed 8 months ago by pili

Keywords: TorBrowserTeam202003 added; TorBrowserTeam202002 removed

We are no longer in February, moving tickets

comment:2 Changed 7 months ago by pili

Keywords: TorBrowserTeam202004 added; TorBrowserTeam202003 removed

We are no longer in March

comment:3 Changed 6 months ago by arma

Is this the same as #30605?

comment:4 in reply to:  3 Changed 6 months ago by Thorin

Replying to arma:

Is this the same as #30605?

Good spotting. Yes. Both about headers on android showing system locale

FYI: the overall (JS/header) problem is even "worse" in Fenix but they were planning some changes (sqsrbq and I checked it out last year), so whatever you do now may be obsolete

comment:5 Changed 6 months ago by gk

Resolution: duplicate
Status: newclosed

Duplicate of #30605.

Note: See TracTickets for help on using tickets.