Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#3351 closed defect (not a bug)

how to create custom circuits...???

Reported by: tor.tor Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

hello..

i was reading about Creating Custom Circuits..
and i found these orders ..but i didnt know how to use them and where to write them..???

Using Tor control protocol you can create custom circuits of different sizes. Regardless of circuit size the last node must be configured as exit-node. In order to successfully create and use custom circuits we must first disable Tor's automatic circuit creation mechanism. While it can not be completely disabled (?), we can still use the following configuration options to force Tor clients to use our custom made circuits:

setconf DisablePredictedCircuits=1 <- disable preemptively creating circuits
setconf MaxOnionsPending=0 <- maximum circuits pending
setconf newcircuitperiod=999999999 <- longer period before creating new circuit
setconf maxcircuitdirtiness=999999999 <- longer period for circuit expiration

You can delete already created circuits so they don't interfere:

closecircuit 2
250 OK
closecircuit 1
250 OK
getinfo circuit-status
250-circuit-status=
250 OK

can somebody help me and give a example to how an where set these orders???

Child Tickets

Change History (3)

comment:1 Changed 7 years ago by nickm

Resolution: not a bug
Status: newclosed

This bugtracker is for tracking bugs, work tickets, and feature requests. It's not a support forum. For that, please try any of the places listed on https://www.torproject.org/docs/documentation.html.en#Support . The IRC channel and or-talk are good bets.

For more information on configuring Tor, look at the manual at https://www.torproject.org/docs/tor-manual.html.en . That documents the configuration options that can go into your torrc file.

For more information on the Tor control port interface, check out https://gitweb.torproject.org/torspec.git/blob/HEAD:/control-spec.txt . That explains how the control protocol works, and documents all of its commands.

comment:2 Changed 5 years ago by nickm

Keywords: tor-relay added

comment:3 Changed 5 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.