Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#3357 closed defect (not a bug)

Comply with the MaxMind license's advertising/documentation clause (metrics website)

Reported by: rransom Owned by: wseltzer
Priority: Medium Milestone:
Component: Metrics/Website Version:
Severity: Keywords:
Cc: phobos Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

From the MaxMind GeoLite license:

2. All advertising materials and documentation mentioning features or use of
this database must display the following acknowledgement:
"This product includes GeoLite data created by MaxMind, available from
http://maxmind.com/"

The web site (at a minimum, metrics.tpo/users.html) appears to be self-documenting. This acknowledgement may also need to be strewn throughout the metrics-db and metrics-tasks documentation.

Child Tickets

Change History (8)

comment:1 Changed 9 years ago by karsten

Priority: criticalnormal

I'm not sure what you mean by the website being "self-documenting."

Should we add the sentence quoted by you to the last section of the footer like below?

"Data on this site is freely available under a CC0 no copyright declaration: To the extent possible under law, the Tor Project has waived all copyright and related or neighboring rights in the data. Graphs are licensed under a Creative Commons Attribution 3.0 United States License. This product includes GeoLite data created by MaxMind, available from http://maxmind.com/."

comment:2 Changed 8 years ago by wseltzer

As with other parts of the site and code, I think it's enough if we have included a link to their license. I don't think the metrics website is a separate "product" that we need to treat differently.

comment:3 in reply to:  2 Changed 8 years ago by karsten

Replying to wseltzer:

As with other parts of the site and code, I think it's enough if we have included a link to their license. I don't think the metrics website is a separate "product" that we need to treat differently.

Hmmm. Can you be more specific what we need to change? For example, if you look at https://metrics.torproject.org/users.html, what sentences or links should we add and where? (See my suggestion to extend the footer by a single sentence above.)

comment:4 Changed 8 years ago by karsten

Owner: changed from karsten to wseltzer
Status: newassigned

I don't know what to do here. Re-assigning to Wendy. Are we doing okay here, or should we change something?

comment:5 Changed 8 years ago by karsten

Status: assignedneeds_information

comment:6 Changed 8 years ago by arma

Let's not go overboard here. If we ship the geoip database in a tarball, we should include a maxmind license in the license file we include in the tarball.

Putting graphs on a web page is not the same as shipping the geoip database. Specifically, the users.html page is not "documentation mentioning features or use of this database". Maxmind does not inherit control over a picture we make using numbers from their phone book. Nor did they invent the names of the countries that we list on that page.

comment:7 Changed 8 years ago by wseltzer

Resolution: not a bug
Status: needs_informationclosed

Agree with arma. Close it as "no action needed."

comment:8 in reply to:  7 Changed 8 years ago by karsten

Replying to wseltzer:

Agree with arma. Close it as "no action needed."

Thanks!

Note: See TracTickets for help on using tickets.