Opened 2 months ago

Closed 8 weeks ago

#33646 closed defect (fixed)

Wrong list of enabled modules

Reported by: Vort Owned by: dgoulet
Priority: Low Milestone: Tor: 0.4.3.x-final
Component: Core Tor/Tor Version: Tor: 0.4.3.2-alpha
Severity: Minor Keywords: build, 043-must, 043-backport, consider-backport-after-ci-passes
Cc: Actual Points: 0.1
Parent ID: Points: 0.1
Reviewer: teor Sponsor:

Description

When I build tor 0.4.3.3-alpha with
./autogen.sh && ./configure --disable-unittests --disable-module-dirauth && make
line, I see following text:

Modules
  relay (--disable-module-relay):                                yes
  dirauth (--disable-module-dirauth):                            yes
  dircache (--disable-module-dircache):                          yes

Which is wrong, since I have enabled relay and disabled dirauth.
Looks like problem is located in commit 9c33d36113447d38decd22d177e62fb225826d78.
Related: #32230.
Please recheck.

Child Tickets

Change History (8)

comment:1 Changed 2 months ago by teor

Keywords: 043-must 043-backport consider-backport-after-ci-passes added
Milestone: Tor: 0.4.3.x-final
Owner: set to dgoulet
Points: 0.1
Status: newassigned
Version: Tor: 0.4.3.3-alphaTor: 0.4.3.2-alpha

Thanks!

Looks like we're missing a $ in xenable_module_mname:

m4_foreach_w([mname], MODULES,
  [
    test "xenable_module_mname" != "xno" && value=1 || value=0
    PPRINT_PROP_BOOL([mname (--disable-module-mname)], $value)
  ]
)

comment:2 Changed 2 months ago by teor

Owner: changed from dgoulet to teor

comment:3 Changed 2 months ago by teor

Actual Points: 0.1
Owner: changed from teor to dgoulet

Hmm, turns out the variables are being expanded before they are set.

I think this is one dgoulet will have to fix.

comment:4 Changed 8 weeks ago by dgoulet

Status: assignedneeds_review

Ok... I had to find m4_foreach_w example online to discover that some special market needs to be added to the expanded variable even though without that it is expanded but doesn't work in the test........!

See PR: https://github.com/torproject/tor/pull/1847

(I think this falls into the "too trivial" for a changes file...?)

comment:5 in reply to:  4 ; Changed 8 weeks ago by teor

Reviewer: teor

Replying to dgoulet:

Ok... I had to find m4_foreach_w example online to discover that some special market needs to be added to the expanded variable even though without that it is expanded but doesn't work in the test........!

Sounds complicated!

See PR: https://github.com/torproject/tor/pull/1847

I think we're using the wrong variables here, see the PR for details.

(I think this falls into the "too trivial" for a changes file...?)

It was released in 0.4.3.2-alpha, and users noticed it, so it needs a changes file.

comment:6 in reply to:  5 Changed 8 weeks ago by arma

Replying to teor:

It was released in 0.4.3.2-alpha, and users noticed it, so it needs a changes file.

Agreed. One of the points of a ChangeLog file is so we can go back and say "oh hey, you remember that thing we had with the automake bug? When was that?" and it's there.

comment:7 Changed 8 weeks ago by dgoulet

Oh indeed teor! Good catched, I only tested with --disable-module-dirauth but the -relay one does more!

So I had to do again some m4 ninjutsu... and I've confirmed it is working now. Also added the changes file as a fixup.

comment:8 Changed 8 weeks ago by teor

Resolution: fixed
Status: needs_reviewclosed

Thanks!

The order is a bit weird, but we can fix that in another ticket, if you want.

Squashed and merged to 0.4.3 and later.

Note: See TracTickets for help on using tickets.