Opened 7 months ago

Closed 6 months ago

#33710 closed defect (duplicate)

Not possible to create New Circuit for websites with redirects

Reported by: alksdjwidmalkszj Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

"New Circuit For This Site" only applies to the currently loaded url, and not the one which redirected to it. Occasionally, when blocking a particular exit node for whatever reason, a website will redirect to a "sorry" webpage at a different URL.

Examples:

youtube.com will redirect to google.com (captcha/spam blocking)

nydailynews.com will redirect to tribpub.com (GDPR blocker)

In the first case, I have been able to work around the problem by visiting youtube.com/about and clicking "new circuit" there. In the second case, I haven't found a suitable workaround. I can't even interrupt the page loading before the redirect occurs because the "new circuit" option doesn't appear until after the page is loaded.

Potential solutions:

  • Allow "new circuit for domain" option, with a field to enter a domain
  • Allow some way to ignore redirects temporarily
  • Add "go but with new circuit" in addition to "go" button to the right in the URL bar
  • Make "new circuit for this site" include redirects to the current site

Child Tickets

Change History (1)

comment:1 Changed 6 months ago by boklm

Keywords: new circuit redirect 302 301 removed
Resolution: duplicate
Status: newclosed

This is a duplicate of #33292.

Note: See TracTickets for help on using tickets.