Opened 7 months ago

Last modified 7 months ago

#33724 needs_information enhancement

Faild Background Update

Reported by: Anonymous75 Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi
i found a problem firefox based browser that fail to update browser in background for example user open tor browser and when opened, automatically update or when users browse the web in tor browser update automatically and when restart browser the new build boot up.
i also check for Automatically install updates (recommended) in Tor Browser Updates.

some one report the bug to Mozilla but they do not any thing(not for now), so for users anonymity and privacy and ... please add a function to tor browser update in background.

regard

Child Tickets

Change History (3)

comment:1 Changed 7 months ago by ner0

At least in Win10 x64 Firfox background updater works automatically, but the first time it is installed it has to be granted full permissions. As for Tor Browser specifically, I was under the impression that it auto-downloads and notifies of an update (still asks permission though).

comment:2 Changed 7 months ago by pili

Priority: ImmediateMedium
Severity: CriticalNormal
Status: newneeds_information

I'm having trouble understanding the enhancement request. As ner0 explains, users are already notified of updates to Tor Browser and asked to restart the browser to install. How is your enhancement request different from the existing functionality?

comment:3 Changed 7 months ago by Anonymous75

ner0 are you say in windows 10 64x work well?? so what about windows 7, 8.1 and linux??
i test all of this have same problem in all build for windows like enterprise and pro(even ultimate in windows 7) also all build of linux but im not test in macOS.
this is old problem affect all firefox and firefox based browser, in old build like tor browser 7.5.1(based on firefox 52.7.0esr) is still working, also old build of firefox work well for update like 52.7.0esr but the problem is new builds not work so please think about it and let me in touch.
sorry for bad eng, regard

Note: See TracTickets for help on using tickets.