Opened 7 weeks ago

Closed 6 weeks ago

#33877 closed defect (fixed)

Disable Samples and Regression tests For Libevent Build

Reported by: sisbell Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-rbm, TorBrowserTeam202004R
Cc: gk, sysrqb, boklm Actual Points:
Parent ID: #28704 Points: .1
Reviewer: gk, boklm Sponsor:

Description

Libevent flags for samples and regression tests aren't part of the final package so remove them from the build for all platforms

--disable-libevent-regress --disable-samples

Child Tickets

Change History (5)

comment:1 Changed 6 weeks ago by sisbell

Status: newneeds_review

I combined the configure_opt_project into this commit since it is needed as part of the configuration. I removed the android part which will be in #28765

--disable-libevent-regress --disable-samples are for all projects now, so I just put them in the build file, as they don't need to be configurable per platform variant.

https://github.com/sisbell/tor-browser-build/commits/bug-33877

comment:2 Changed 6 weeks ago by sisbell

Keywords: TorBrowserTeam202004R added; TorBrowserTeam202004 removed

comment:3 Changed 6 weeks ago by sysrqb

Reviewer: gk, boklm

For Linux, does it make sense to move this:

       linux-x86_64: 1
       osname: linux-x86_64
+      configure_opt: '[% c("var/configure_opt_project") %]'
       # We only support RLBox on the nightly channel and x86_64 for now
       rlbox: '[% c("var/nightly") %]'

from linux-x86_64, and declare configure_opt under linux such that it is inherited by linux-x86_64 and any new Linux arch we add?

comment:4 Changed 6 weeks ago by sisbell

Moved 'configure_opt' from linux-x86_64 var to linux var

https://github.com/sisbell/tor-browser-build/commits/bug-33877a

comment:5 in reply to:  1 Changed 6 weeks ago by boklm

Resolution: fixed
Status: needs_reviewclosed

Replying to sisbell:

I combined the configure_opt_project into this commit since it is needed as part of the configuration. I removed the android part which will be in #28765

--disable-libevent-regress --disable-samples are for all projects now, so I just put them in the build file, as they don't need to be configurable per platform variant.

There is no need for configure_opt_project to add the --disable-libevent-regress --disable-samples flags to projects/libevent/build. So I think it does not make sense to combine the configure_opt_project changes with this commit. Instead it should be a separate commit, or combined with the patch for #28765 (where configure_opt_project is needed).

But in order to avoid another round of reviews, I moved the configure_opt_project changes myself from the #33877 patch to the #28765 patch. I also fixed a typo in the commit message for #28765 (removing the - after Bug). This is now commits f4792f507d57583fce4f52afcb927076762653a1 (#33877) and 06bb0f2d4c91d7ac60ae180297d3c0707a004199 (#28765) on master.

Note: See TracTickets for help on using tickets.