Opened 9 years ago

Closed 9 years ago

#3388 closed defect (not a bug)

Torbutton 1.3.3-alpha not masking User Agent by default in FF 4.0.1

Reported by: dennismckernan Owned by: mikeperry
Priority: Medium Milestone: Torbutton: 1.4
Component: Applications/Torbutton Version: Torbutton: 1.3.0-alpha
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Dear Tor Developers,

Mozilla Firefox 4.0.1 with Torbutton 1.3.3-alpha installed is not masking the User Agent to the default Tor User Agent. Instead it reports the correct OS and Firefox 4.0.1 User Agent.

I ran the User Agent test at the following sites:
http://ip-check.info/?lang=en
http://whatismyuseragent.dotdoh.com

Please fix this before the final release!
Please feel free to contact me with any questions.
Thanks for the great software!
:)

Child Tickets

Change History (3)

comment:1 Changed 9 years ago by tagnaq

Hi dennismckernan,

I guess you think that Torbutton 1.3.3-alpha is not masking because in your case it matches the real world settings (windows + firefox 4), but if you use Torbutton 1.3.3-alpha on FreeBSD/Firefox 3.6.x
it will also report the following User-Agent String:

Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

so I would say this is not a bug. The UA String in Torbutton just changed from v1.3.2-alpha -> 1.3.3-alpha

comment:3 Changed 9 years ago by mikeperry

Resolution: not a bug
Status: newclosed
Note: See TracTickets for help on using tickets.