Opened 7 months ago

Closed 5 months ago

#33886 closed defect (duplicate)

bridges@torproject.org Don't respond to gmail

Reported by: mh828 Owned by: phw
Priority: Medium Milestone:
Component: Circumvention/BridgeDB Version:
Severity: Normal Keywords: bridgedb-reportbug
Cc: cohosh, phw Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

hi,
i sent mail to bridges@… with body "get bridges" by gmail but it don't respond to me

Child Tickets

Change History (2)

comment:1 Changed 7 months ago by phw

Owner: set to phw
Status: newassigned

Thanks for your bug report! This may be caused by the following exception that BridgeDB occasionally raises:

Unhandled Error
Traceback (most recent call last):
  File "/home/bridgedb/virtualenvs/bridgedb/lib/python3.7/site-packages/twisted/python/log.py", line 103, in callWithLogger
    return callWithContext({"system": lp}, func, *args, **kw)
  File "/home/bridgedb/virtualenvs/bridgedb/lib/python3.7/site-packages/twisted/python/log.py", line 86, in callWithContext
    return context.call({ILogContext: newCtx}, func, *args, **kw)
  File "/home/bridgedb/virtualenvs/bridgedb/lib/python3.7/site-packages/twisted/python/context.py", line 122, in callWithContext
    return self.currentContext().callWithContext(ctx, func, *args, **kw)
  File "/home/bridgedb/virtualenvs/bridgedb/lib/python3.7/site-packages/twisted/python/context.py", line 85, in callWithContext
    return func(*args,**kw)
--- <exception caught here> ---
  File "/home/bridgedb/virtualenvs/bridgedb/lib/python3.7/site-packages/twisted/internet/posixbase.py", line 614, in _doReadOrWrite
    why = selectable.doRead()
  File "/home/bridgedb/virtualenvs/bridgedb/lib/python3.7/site-packages/twisted/internet/tcp.py", line 243, in doRead
    return self._dataReceived(data)
  File "/home/bridgedb/virtualenvs/bridgedb/lib/python3.7/site-packages/twisted/internet/tcp.py", line 249, in _dataReceived
    rval = self.protocol.dataReceived(data)
  File "/home/bridgedb/virtualenvs/bridgedb/lib/python3.7/site-packages/twisted/protocols/basic.py", line 454, in dataReceived
    self.lineReceived(line)
  File "/home/bridgedb/virtualenvs/bridgedb/lib/python3.7/site-packages/twisted/mail/smtp.py", line 445, in lineReceived
    return getattr(self, 'state_' + self.mode)(line)
  File "/home/bridgedb/virtualenvs/bridgedb/lib/python3.7/site-packages/twisted/mail/smtp.py", line 705, in dataLineReceived
    m.eomReceived() for m in self.__messages
  File "/home/bridgedb/virtualenvs/bridgedb/lib/python3.7/site-packages/twisted/mail/smtp.py", line 705, in <listcomp>
    m.eomReceived() for m in self.__messages
  File "/home/bridgedb/virtualenvs/bridgedb/lib/python3.7/site-packages/bridgedb-0.10.0+9.g208b49cd.dirty-py3.7.egg/bridgedb/distributors/email/server.py", line 240, in eomReceived
    self.responder.reply()
  File "/home/bridgedb/virtualenvs/bridgedb/lib/python3.7/site-packages/bridgedb-0.10.0+9.g208b49cd.dirty-py3.7.egg/bridgedb/distributors/email/autoresponder.py", line 603, in reply
    response = self.getMailData()
  File "/home/bridgedb/virtualenvs/bridgedb/lib/python3.7/site-packages/bridgedb-0.10.0+9.g208b49cd.dirty-py3.7.egg/bridgedb/distributors/email/autoresponder.py", line 420, in getMailData
    client, lang)
  File "/home/bridgedb/virtualenvs/bridgedb/lib/python3.7/site-packages/bridgedb-0.10.0+9.g208b49cd.dirty-py3.7.egg/bridgedb/distributors/email/autoresponder.py", line 102, in createResponseBody
    bridges = context.distributor.getBridges(bridgeRequest, interval)
  File "/home/bridgedb/virtualenvs/bridgedb/lib/python3.7/site-packages/bridgedb-0.10.0+9.g208b49cd.dirty-py3.7.egg/bridgedb/distributors/email/distributor.py", line 149, in getBridges
    with bridgedb.Storage.getDB() as db:
  File "/home/bridgedb/virtualenvs/bridgedb/lib/python3.7/site-packages/bridgedb-0.10.0+9.g208b49cd.dirty-py3.7.egg/bridgedb/Storage.py", line 352, in __enter__
    return next(self.gen)
  File "/home/bridgedb/virtualenvs/bridgedb/lib/python3.7/site-packages/bridgedb-0.10.0+9.g208b49cd.dirty-py3.7.egg/bridgedb/Storage.py", line 472, in getDB
    assert _REFCOUNT == 0
builtins.AssertionError:

Hmm, I wonder if our recent port to Python 3 broke our context manager. Email distribution did work in the recent past, so the issue is probably a bit more nuanced.

comment:2 Changed 5 months ago by phw

Resolution: duplicate
Status: assignedclosed

We fixed this issue over at #33945. The autoresponder has been working ever since we deployed the fix.

Note: See TracTickets for help on using tickets.