Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#3389 closed defect (fixed)

0.2.3.1 tarball doesn't contain tor-fw-helper manpage

Reported by: Sebastian Owned by:
Priority: Medium Milestone: Tor: 0.2.3.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Stephen Walker reports that building from the 0.2.3.1 tarball fails when the --enable-upnp option is passed during configure. Because we didn't want to build the manpage when it isn't needed, we also didn't include it in the tarball if --enable-upnp or --enable-nat-pmp didn't get passed during configure.

Child Tickets

Change History (5)

comment:1 Changed 8 years ago by Sebastian

Idea for a fix in branch bug3389 ( https://gitweb.torproject.org/sebastian/tor.git/commitdiff/bug3389 ). I wasn't quite able to test it other than looking at the tarball and making sure it contains the manpage: Building with either nat-pmp or miniupnpc is a huge pita, because they change their API between versions all the time. If someone who is currently building with either natpmp or upnp support could test this that would be great.

comment:2 Changed 8 years ago by Sebastian

Status: newneeds_review

comment:3 Changed 8 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

Looks good to me; merging.

comment:4 Changed 7 years ago by nickm

Keywords: tor-client added

comment:5 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.