Opened 8 years ago

Closed 8 years ago

#3398 closed defect (fixed)

toolbarbutton popup is transparent in firefox 4

Reported by: arno Owned by: mikeperry
Priority: Medium Milestone:
Component: Applications/Torbutton Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi,
in firefox 4, the toolbarbutton menu is transparent (see attached screenshot).
When using a <menupopup/> instead of a <popup/> for torbutton-context-menu, the bug disappears.
I tested firefox 3.0, 3.5 and 3.6 to check it did not break the menu (I did not test in thunderbird though).

Child Tickets

Attachments (2)

torbutton_menu.png (14.0 KB) - added by arno 8 years ago.
screenshot
3398.patch (1.9 KB) - added by arno 8 years ago.
proposed fix

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by arno

Attachment: torbutton_menu.png added

screenshot

Changed 8 years ago by arno

Attachment: 3398.patch added

proposed fix

comment:1 Changed 8 years ago by arno

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by rransom

Resolution: duplicate
Status: closedreopened

This ticket is a duplicate of #2360, but I'm reopening it because this ticket now has a patch attached to it.

comment:3 Changed 8 years ago by rransom

Status: reopenedneeds_review

comment:4 Changed 8 years ago by mikeperry

Resolution: fixed
Status: needs_reviewclosed

Damnit, I fixed this myself in 1.4.0 but didn't see this ticket+patch because it was in Torbutton and not TorBrowserButton. Oh well.

Note: See TracTickets for help on using tickets.