Opened 8 weeks ago

Closed 7 weeks ago

#34242 closed defect (fixed)

Creating containers for Linux targets is busted due to outdated apt

Reported by: gk Owned by: gk
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-rbm, TorBrowserTeam202005R, GeorgKoppen202005
Cc: tbb-team Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

For Linux containers we hardcode 0.9.7.9+deb7u8 as the minimal apt version but that's not available anymore on deb.freexian.com. Rather it's 0.9.7.9+deb7u9 now.

Child Tickets

Change History (4)

comment:1 Changed 8 weeks ago by gk

bug_34242 (https://gitweb.torproject.org/user/gk/tor-browser-build.git/commit/?h=bug_34242&id=e9fa09b87bd633f10cfeca2797839662138d5d39) has the changes up for review.

However, it seems I still can't build containers successfully again. The debootstrap-image part is still failing, although differently now:

W: Failure trying to run: chroot "/var/tmp/tmp.HiqNC7Q599/base-image" dpkg --force-depends --install /var/cache/apt/archives/base-passwd_3.5.26_amd64.deb
W: See /var/tmp/tmp.HiqNC7Q599/base-image/debootstrap/debootstrap.log for details

And the end of that log says:

2020-05-17 19:15:26 URL:http://archive.debian.org/debian/pool/main/z/zlib/zlib1g_1.2.7.dfsg-13_amd64.deb [87392/87392] -> "/var/tmp/tmp.uv7kNeRkLc/base-image//var/cache/apt/archives/partial/zlib1g_1%3a1.2.7.dfsg-13_amd64.deb" [1]
dpkg: warning: parsing file '/var/lib/dpkg/status' near line 5 package 'dpkg':
 missing description
dpkg: warning: parsing file '/var/lib/dpkg/status' near line 5 package 'dpkg':
 missing architecture
Segmentation fault

Hrm.

comment:2 in reply to:  1 ; Changed 8 weeks ago by gk

Keywords: TorBrowserTeam202005R added; TorBrowserTeam202005 removed
Status: assignedneeds_review

Replying to gk:

[snip]

However, it seems I still can't build containers successfully again. The debootstrap-image part is still failing, although differently now:

W: Failure trying to run: chroot "/var/tmp/tmp.HiqNC7Q599/base-image" dpkg --force-depends --install /var/cache/apt/archives/base-passwd_3.5.26_amd64.deb
W: See /var/tmp/tmp.HiqNC7Q599/base-image/debootstrap/debootstrap.log for details

And the end of that log says:

2020-05-17 19:15:26 URL:http://archive.debian.org/debian/pool/main/z/zlib/zlib1g_1.2.7.dfsg-13_amd64.deb [87392/87392] -> "/var/tmp/tmp.uv7kNeRkLc/base-image//var/cache/apt/archives/partial/zlib1g_1%3a1.2.7.dfsg-13_amd64.deb" [1]
dpkg: warning: parsing file '/var/lib/dpkg/status' near line 5 package 'dpkg':
 missing description
dpkg: warning: parsing file '/var/lib/dpkg/status' near line 5 package 'dpkg':
 missing architecture
Segmentation fault

Hrm.

*That* in turn does only happen on one of the machines I have available. So, this ticket seems to be unrelated to that problem at least.

comment:3 in reply to:  2 Changed 8 weeks ago by gk

Replying to gk:

Replying to gk:

[snip]

However, it seems I still can't build containers successfully again. The debootstrap-image part is still failing, although differently now:

W: Failure trying to run: chroot "/var/tmp/tmp.HiqNC7Q599/base-image" dpkg --force-depends --install /var/cache/apt/archives/base-passwd_3.5.26_amd64.deb
W: See /var/tmp/tmp.HiqNC7Q599/base-image/debootstrap/debootstrap.log for details

And the end of that log says:

2020-05-17 19:15:26 URL:http://archive.debian.org/debian/pool/main/z/zlib/zlib1g_1.2.7.dfsg-13_amd64.deb [87392/87392] -> "/var/tmp/tmp.uv7kNeRkLc/base-image//var/cache/apt/archives/partial/zlib1g_1%3a1.2.7.dfsg-13_amd64.deb" [1]
dpkg: warning: parsing file '/var/lib/dpkg/status' near line 5 package 'dpkg':
 missing description
dpkg: warning: parsing file '/var/lib/dpkg/status' near line 5 package 'dpkg':
 missing architecture
Segmentation fault

Hrm.

*That* in turn does only happen on one of the machines I have available. So, this ticket seems to be unrelated to that problem at least.

I filed #34243 for that one.

comment:4 Changed 7 weeks ago by sysrqb

Resolution: fixed
Status: needs_reviewclosed

Patch looks good, and sha256 hashes confirmed. Thanks!

Merged with commit e202334a89191016e6419fe5cbedd965727b3103.

Note: See TracTickets for help on using tickets.