Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#3464 closed defect (duplicate)

Assertion at startup on Windows 7 when socketpair fails

Reported by: special Owned by:
Priority: Medium Milestone: Tor: 0.2.3.x-final
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Keywords: tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Startup of a fresh install of the Vidalia bundle, Tor version 0.2.2.29, no torrc:

[warn] Warning from libevent: evsig_init: socketpair: Connection refused [WSAECONNREFUSED ]
[warn] Warning from libevent: evthread_make_base_notifiable: socketpair: Connection refused [WSAECONNREFUSED ]
[err] Error from libevent: event.c:1409: Assertation base failed in event_base_get_method

Child Tickets

Change History (8)

comment:1 Changed 8 years ago by special

Resolution: invalid
Status: newclosed

Ugh, nevermind. Traced this to other malfunctioning software on the system.

comment:2 Changed 8 years ago by rransom

Resolution: invalid
Status: closedreopened
Summary: Assertation at startup on Windows 7Assertion at startup on Windows 7 when socketpair fails

We shouldn't die with an assertion failure here, even if something is forbidding Tor from connecting a socket to itself on the loopback address.

comment:3 Changed 8 years ago by Sebastian

Milestone: Tor: 0.2.2.x-finalTor: 0.2.3.x-final

Seems like a bug that can safely wait for 0.2.3.x

comment:4 Changed 8 years ago by arma

Apparently we just closed bug #4457, which had an identical name to this one.

...Is it related?

comment:5 in reply to:  4 Changed 8 years ago by cypherpunks

Replying to arma:

Apparently we just closed bug #4457, which had an identical name to this one.

...Is it related?

It's the same till the last bit.

comment:6 Changed 8 years ago by Sebastian

Resolution: duplicate
Status: reopenedclosed

Closing as duplicate of #4457

comment:7 Changed 7 years ago by nickm

Keywords: tor-client added

comment:8 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.