Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#3468 closed defect (not a bug)

Some popular hidden services are failing

Reported by: chuckles Owned by: rransom
Priority: High Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords: tor-hs
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Certain hidden services (the example hidden service, DuckDuckGo) work flawlessly, but others, notably the hidden wiki (along with some others) have been unable to be accessed for well over three weeks now.

I have, of course, changed .tor2web.org to .onion, but alas, instead of a SOCKS error Firefox is now reporting that the connection is taking too long to respond.

Used to be able to access everything fine; now it's having issues. Tried with an old Tor Browser Bundle (Jan 2011) and then deleted and used a new one dl'd on the 24th June. Still nothing.

Any solutions?

Child Tickets

Change History (7)

comment:1 Changed 8 years ago by rransom

Component: Tor BrowserTor Hidden Services
Status: newassigned
Summary: Hidden Services - Hit and MissSome popular hidden services are failing

DuckDuckGo operates two exit-enclave relays, and I assume the DDG hidden service is run on one of those relays. I suspect that the example hidden service is also run on a relay.

But the others are probably not run on relays (because we recommend that they not be, in order to prevent certain attacks). Thus, their Tor TLS connections are now being throttled to about 40 kiB/s in each direction, and that will make a popular hidden service completely inaccessible (due to both increased latency and decreased throughput).

There are ways that these hidden services' operators (and BitTorrent users) can avoid this throttling, but a normal Tor client will not avoid it (and should not have to).

comment:2 Changed 8 years ago by mikeperry

Actually, the throttling has not been applied for some time now. We ran an experiment back at the end of April/beginning of May and have not re-enabled it since.

comment:3 in reply to:  2 ; Changed 8 years ago by rransom

Owner: changed from mikeperry to rransom

Replying to mikeperry:

Actually, the throttling has not been applied for some time now. We ran an experiment back at the end of April/beginning of May and have not re-enabled it since.

In that case, it may be a problem with the hidden services themselves, and there's nothing we can do about that.

Or, depending on the TBB you're using, it may be #1297. Try the alpha version of Tor Browser Bundle released on 2011-06-25; the version of Tor in that bundle contains a major bugfix for hidden service clients.

comment:4 in reply to:  3 Changed 8 years ago by chuckles

Many thanks for suggesting trying the alpha version (2.2.29-1 was the version you were referring to, right?); unfortunately, it still times out.

Your assessment that it's the services themselves rather than user error could well be correct, I was just very surprised that there was no word of it; normally they don't go down for so long and so silently.

comment:5 Changed 8 years ago by rransom

Resolution: not a bug
Status: assignedclosed

comment:6 Changed 7 years ago by nickm

Keywords: tor-hs added

comment:7 Changed 7 years ago by nickm

Component: Tor Hidden ServicesTor
Note: See TracTickets for help on using tickets.