Opened 8 years ago

Closed 3 years ago

#3528 closed defect (duplicate)

Torbutton menu does not appear when navigation bar is disabled.

Reported by: cowsarenotevil Owned by: mikeperry
Priority: Medium Milestone:
Component: Applications/Torbutton Version: Torbutton: 1.4.0
Severity: Normal Keywords: navigation toolbar menu
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I have the Navigation Toolbar disabled in Firefox 5 since all of my buttons are on the tabs bar. For some reason, this prevents the menu from appearing when I click on the Torbutton icon (the menu which contains "Toggle Tor status"). If I enable the (empty) Navigation Toolbar, the menu appears fine, but I would naturally prefer not to need to do this since it takes up screen space.

Is there a better workaround/is the menu supposed to be necessary to turn Tor on and off?

Thanks

Child Tickets

Change History (2)

comment:1 Changed 8 years ago by alex

While waiting for the developers to fix the problem, I managed to use the following workaround:

  • Unzip the torbutton XPI file, preserving directory structure
  • Edit chrome/content/torbutton.js and chrome/content/torbutton.xul
  • In those two files, replace all instances of nav-bar with addon-bar
  • Zip up all the files, preserving directory structure, into a new XPI file
  • Install the new XPI file manually

Once I did that, I could hide the navigation toolbar. It worked for me; I offer no guarantees that this will work for you. I'm not a programmer; I just fiddled around and guessed and used Google to look for information about toolbar IDs.

comment:2 Changed 3 years ago by bugzilla

Resolution: duplicate
Severity: Normal
Status: newclosed

Closed as a duplicate of #3637.

Note: See TracTickets for help on using tickets.