Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#3536 closed defect (fixed)

Tor sends a RESOLVEFAILED event when a reverse lookup succeeds.

Reported by: katmagic Owned by:
Priority: Low Milestone: Tor: 0.2.2.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Having SETEVENTS ADDRMAP and STREAM, I get

650 STREAM 23575 NEWRESOLVE 0 8.8.8.8:0 PURPOSE=DNS_REQUEST
650 STREAM 23575 NEW 7180 8.8.8.8:0 SOURCE_ADDR=(Tor_internal):58649 PURPOSE=DNS_REQUEST
650 STREAM 23575 SENTRESOLVE 7180 8.8.8.8:0
650 ADDRMAP REVERSE[8.8.8.8] google-public-dns-a.google.com "2011-07-07 01:55:07" EXPIRES="2011-07-07 05:55:07"
650 STREAM 23575 FAILED 7180 8.8.8.8:0 REASON=RESOLVEFAILED
650 STREAM 23575 CLOSED 7180 8.8.8.8:0 REASON=DONE

or something similar with any successful reverse DNS request. I'm using 0.2.3.1-alpha-dev (git-e273890b10092b0a).

Child Tickets

Change History (6)

comment:1 Changed 8 years ago by rransom

Component: - Select a componentTor Client

comment:2 Changed 8 years ago by katmagic

arma suspects this is caused by the end of connection_ap_handshake_socks_resolved(), and notes how connection_ap_handshake_socks_reply() sends a control_event_stream_status().

comment:3 Changed 8 years ago by Sebastian

Milestone: Tor: 0.2.2.x-final
Status: newneeds_review

Added a patch for this in bug3536 in my repository. I tested that: a) regular DNS resolves via tor-resolve still work as expected - they fail for non-existent domains and work for existent ones, b) reverse DNS now works as expected: an attached controller doesn't get the RESOLVEFAILED message when a resolve succeeds, but still gets it when a resolve failed (tested with 1.1.1.1 for example).

comment:4 Changed 8 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

Looks okay to me. Merged.

comment:5 Changed 7 years ago by nickm

Keywords: tor-client added

comment:6 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.