Opened 8 years ago

Closed 8 years ago

#3537 closed defect (fixed)

Polipo instructions got removed from the website

Reported by: Sebastian Owned by: phobos
Priority: Medium Milestone:
Component: Webpages/Website Version:
Severity: Keywords:
Cc: erinn, aagbsn@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This means that now *BSD users don't get the configuration information (we don't offer TBBs for them), it means that our Debian package users get a proxy installed but will not configure it, etc. Just pretending TBB is the answer for everyone doesn't work imo because we don't support TBB for everyone, and our packages assume that installing polipo is still necessary. I suspect you will have to persuade weasel that the tor debian package is not supposed to be used as a client to get the proxy recommendation removed.

Child Tickets

Change History (10)

comment:1 in reply to:  description Changed 8 years ago by rransom

Replying to Sebastian:

This means that now *BSD users don't get the configuration information (we don't offer TBBs for them),

BSD users can install and use Firefox 5 now, and at least be able to browse the web through Tor without using Polipo. (Someone should tell them that.)

comment:2 Changed 8 years ago by phobos

As a freebsd user, tbb for linux works fine inside it.

comment:3 in reply to:  description ; Changed 8 years ago by phobos

Replying to Sebastian:

This means that now *BSD users don't get the configuration information (we don't offer TBBs for them), it means that our Debian package users get a proxy installed but will not configure it, etc. Just pretending TBB is the answer for everyone doesn't work imo because we don't support TBB for everyone, and our packages assume that installing polipo is still necessary. I suspect you will have to persuade weasel that the tor debian package is not supposed to be used as a client to get the proxy recommendation removed.

I was unaware we still ship polipo in our bundles, nor have the software pointers to it. Polipo and privoxy are no longer needed, and haven't been for ages. Polipo/Privoxy were needed when Tor's average latency was 10+ seconds. Now, with tor's less than 5 second response, on average, even firefox 3.6.18 using socks direct to Tor rarely results in a confusing 'network error'.

We shouldn't be instructing users to install either package. When I installed torbutton 1.3.3-alpha, it did not have "use polipo" checked by default. Now that torbutton 1.4 is released, we really don't need to point people at polipo.

Feel free to revert my changes. My end goal is clearly stated at https://lists.torproject.org/pipermail/tor-dev/2011-June/002780.html

comment:4 in reply to:  3 Changed 8 years ago by runa

Replying to phobos:

I was unaware we still ship polipo in our bundles, nor have the software pointers to it. Polipo and privoxy are no longer needed, and haven't been for ages. Polipo/Privoxy were needed when Tor's average latency was 10+ seconds. Now, with tor's less than 5 second response, on average, even firefox 3.6.18 using socks direct to Tor rarely results in a confusing 'network error'.

I can confirm that we are shipping Polipo 1.0.4.1 in the stable Vidalia Bundle for Windows. We should build new packages and update the website if Polipo is no longer needed.

comment:5 Changed 8 years ago by weasel

Cc: weasel removed

comment:6 in reply to:  3 Changed 8 years ago by aagbsn

Cc: aagbsn@… added

Replying to phobos:

Replying to Sebastian:

This means that now *BSD users don't get the configuration information (we don't offer TBBs for them), it means that our Debian package users get a proxy installed but will not configure it, etc. Just pretending TBB is the answer for everyone doesn't work imo because we don't support TBB for everyone, and our packages assume that installing polipo is still necessary. I suspect you will have to persuade weasel that the tor debian package is not supposed to be used as a client to get the proxy recommendation removed.

I was unaware we still ship polipo in our bundles, nor have the software pointers to it. Polipo and privoxy are no longer needed, and haven't been for ages. Polipo/Privoxy were needed when Tor's average latency was 10+ seconds. Now, with tor's less than 5 second response, on average, even firefox 3.6.18 using socks direct to Tor rarely results in a confusing 'network error'.

Note that Debian auto-installs recommendations by default and TPI .deb packages recommend polipo (as of 7/18/2011). This might be confusing to users because polipo is installed if they follow the instructions. Perhaps we can remove polipo from the list of recommended packages? Or mention "polipo can provide a HTTP proxy; the recommended configuration for use with Tor is <link-to-config>"

We shouldn't be instructing users to install either package. When I installed torbutton 1.3.3-alpha, it did not have "use polipo" checked by default. Now that torbutton 1.4 is released, we really don't need to point people at polipo.

Feel free to revert my changes. My end goal is clearly stated at https://lists.torproject.org/pipermail/tor-dev/2011-June/002780.html

comment:7 Changed 8 years ago by runa

We should also remove the link to polipo on https://www.torproject.org/docs/tor-doc-unix.html.en#polipo on https://www.torproject.org/docs/debian.html.en (link text is "step two").

comment:8 Changed 8 years ago by phobos

now that we don't ship polipo anymore, do we still need polipo instructions? Or we could create a wiki page and point people at that.

comment:9 Changed 8 years ago by arma

I hope to make https://www.torproject.org/docs/faq#TBBPolipo the one-stop shop for polipo info. Is there anything it's missing?

comment:10 Changed 8 years ago by phobos

Resolution: fixed
Status: newclosed

Sounds good for now.

Note: See TracTickets for help on using tickets.