Opened 9 years ago

Closed 8 years ago

#3635 closed defect (not a bug)

Start/stop tor is not logical

Reported by: joergent Owned by: chiiph
Priority: Low Milestone:
Component: Archived/Vidalia Version: Vidalia: 0.2.12
Severity: Keywords:
Cc: opensource@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Vidalia should not be using the 'Start tor' phrase, when it actually is a 'Connect to' function

It is also inconsistent with the result phrase
"Connected to the Tor Network!"

Starting tor is controlled by a configuration option and not invoked by clicking the current Start button

Start/Stop tor is different from Connect to/Disconnect from tor, so when a connection has been established, a "Disconnect button" is missing.
Clicking the Exit button will do, however.

Child Tickets

Change History (3)

comment:1 Changed 9 years ago by joergent

Milestone: Vidalia: 0.2.13

comment:2 Changed 9 years ago by Sebastian

While I agree in principle this is not accurate for the most common Vidalia usage. Any solution we come uo with should not end up with a more complex description of the action taken.

comment:3 Changed 8 years ago by chiiph

Resolution: not a bug
Status: newclosed

This kind of bugs are really difficult to work on. I also agree it's a particular issue, but I think the most common way of looking at this is that most users think Vidalia==tor, then what they want is to get it started. It's not that common to see the regular user actually understand that the software is connecting somehow to a network of relays and so on.

So I'm going to close this for now, unless there is more people behind this.

Note: See TracTickets for help on using tickets.