Opened 8 years ago

Closed 7 years ago

#3670 closed defect (invalid)

remove some torsocks dependencies

Reported by: phobos Owned by:
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

torsocks in squeeze and ubuntu require installing:
The following extra packages will be installed:

libevent-1.4-2 polipo tor tor-geoipdb tsocks

If one has torbrowser running, there is no need to install tor and tor-geoipdb.

Polipo should be removed from torsocks dependency altogether.

Child Tickets

Change History (2)

comment:1 Changed 7 years ago by erinn

Owner: erinn deleted
Status: newassigned

I don't maintain torsocks in Debian or Ubuntu so I'm going to unassign this from myself, but maybe it should be closed or re-filed on the Debian and Ubuntu bug tracking systems?

comment:2 Changed 7 years ago by rransom

Resolution: invalid
Status: assignedclosed

torsocks ‘recommends’ tor, because most people who want to use the torsocks package will also want to have the tor package installed.

At the time that this ticket was opened, tor recommended polipo and tsocks. That has been fixed in the packages in which weasel can fix it.

Note: See TracTickets for help on using tickets.