Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#3680 closed defect (duplicate)

Spec missing CIRC PURPOSE field

Reported by: atagar Owned by:
Priority: Low Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

CIRC events have a PURPOSE keyword field, for instance...

63 CLOSED $24518FFB7C78DAA9E1962538B544494B6AD1A7C4=FFTTZZ,<...etc> PURPOSE=GENERAL REASON=FINISHED

However this isn't reflected in the control spec. This field comes from circuit_purpose_to_controller_string of circuitlist.c so valid options are "SERVER", "GENERAL", "HS_CLIENT_INTRO", "HS_CLIENT_REND", "HS_SERVICE_INTRO", "HS_SERVICE_REND", "TESTING", "MEASURE_TIMEOUT", "CONTROLLER", and "UNKNOWN_<int>".

Child Tickets

Change History (5)

comment:1 Changed 8 years ago by rransom

Resolution: duplicate
Status: newclosed

Duplicate of #2411.

comment:2 Changed 8 years ago by nickm

I'm assuming you marked this as duplicate of #2411 not because it is the same issue, but because it's fixed by the same patch?

comment:3 in reply to:  2 Changed 8 years ago by rransom

Replying to nickm:

I'm assuming you marked this as duplicate of #2411 not because it is the same issue, but because it's fixed by the same patch?

It's mentioned in the ticket description of #2411 (“Right now we export a PURPOSE= argument, but the string we send isn't very useful.”), and it's almost fixed in the first commit on my bug2411a-v2 branch (I missed MEASURE_TIMEOUT).

comment:4 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:5 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.