Opened 8 years ago

Closed 8 years ago

#3696 closed defect (fixed)

Learn how to write your own rulesets link opens window that you can't scroll in

Reported by: henare Owned by: jacobske87
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: jacobske87@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

To reproduce:

  • Go to HTTPS preferences
  • Click the link at the bottom of the preferences screen
  • A browser window without chrome is opened and you can't scroll the page to read all of the information

It should just open the page in a browser tab

Child Tickets

Attachments (1)

https-everywhere-latest.xpi (123.2 KB) - added by jacobske87 8 years ago.
Possible fix (please verify with Tor)

Download all attachments as: .zip

Change History (7)

comment:1 Changed 8 years ago by rransom

Component: - Select a componentEFF-HTTPS Everywhere
Owner: set to pde

comment:2 Changed 8 years ago by jacobske87

Cc: jacobske87@… added
Owner: changed from pde to jacobske87
Status: newassigned

Confirmed bug, and I copied over a potential fix from my own extension. I don't have Tor installed so I haven't tested with that (regarding the state control button comment line), but since it uses the same window I don't think it should cause any problems.

I think the added tab is much more user friendly than opening a new window.

Code change is here: https://github.com/kevinjacobs/HTTPS-Everywhere/commit/6b6c50e6b925b13356063b1bb589fe834ccc77bd (ignore the deleted folder change)

comment:3 Changed 8 years ago by mikeperry

Looks ok, except I think that browser will always be undefined because this code executes from the about.xul window.

Have you successfully tested it w/ torbutton?

comment:4 Changed 8 years ago by jacobske87

As for the undefined browser (if/else).. You're probably right, I just copied it from my code where it's intended to be reusable (so I can call the same method when browser is defined). It will still work but the if/else is up to you whether you'd want in there or not.

I won't be able to test with Tor until this weekend. I'll give it a try and post my results.

Changed 8 years ago by jacobske87

Attachment: https-everywhere-latest.xpi added

Possible fix (please verify with Tor)

comment:5 Changed 8 years ago by jacobske87

Status: assignedneeds_review

It seems to work with Tor just fine for me. I'm not really a Tor user though, so it would be better if someone who knows it could verify that the fix is safe..

I attached the modified XPI for you to test. Thanks

comment:6 Changed 8 years ago by jacobske87

Resolution: fixed
Status: needs_reviewclosed
Note: See TracTickets for help on using tickets.