Opened 8 years ago

Closed 8 years ago

#3697 closed defect (duplicate)

TBB 2.2.30-2-alpha for Windows does not disable Live Bookmarks

Reported by: rransom Owned by: mikeperry
Priority: Medium Milestone:
Component: TorBrowserButton Version:
Severity: Keywords:
Cc: erinn, mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When I started a newly extracted TBB 2.2.30-2-alpha for Windows for the first time, I noticed a connection to feeds.bbci.co.uk:80 in Vidalia's 'Network Map' window -- Mozilla's 'Latest Headlines' Live Bookmark was present in the 'Bookmarks Toolbar' bookmark folder and working. Firefox refreshed that RSS feed again the second time I started the TBB, and again when I clicked the 'Reload Live Bookmark' context menu item for that bookmark. Torbutton/TorBrowserButton should completely prevent these fetches.

(We may want to enable Live Bookmarks in a later TBB version, but we can't enable them safely until TBB ships Tor 0.2.3.x and TBB-Firefox has been patched to use the SOCKS authentication fields to isolate its streams.)

Child Tickets

Change History (3)

comment:1 Changed 8 years ago by rransom

This is probably a duplicate of #2847.

comment:2 Changed 8 years ago by mikeperry

Priority: blockernormal

Why is the default set of feeds particularly dangerous?

And even if it is dangerous, shouldn't we just empty it out?

What privacy gain do we get from disabling this feature in TBB? I was of the opinion that this was only an issue for Torbutton/toggle mode (where your set of Firefox RSS feeds could easily deanonymize you through tor vs non-tor correlation). But, if you have a set of RSS feeds you want to use specifically with Tor Browser, why shouldn't you be allowed to use them?

comment:3 Changed 8 years ago by mikeperry

Resolution: duplicate
Status: newclosed

Sebastian is tackling this in #5163.

Note: See TracTickets for help on using tickets.