Opened 8 years ago

Closed 8 years ago

Last modified 2 years ago

#3738 closed defect (fixed)

weird behavior in Vidalia 0.2.13

Reported by: erinn Owned by: chiiph
Priority: Immediate Milestone:
Component: Archived/Vidalia Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I began making Vidalia bundles for the 0.2.13 release. After removing my ~/.tor and ~/Library/Vidalia directories, I installed and ran the new bundle (while running TBB, to make sure the new port selection stuff worked) and had a few different issues which I'll list below and which may all need to be separated into different bugs (for which this could become the parent bug):

  1. Vidalia complains it can't find /Users/erinn/.tor/port.conf and stops loading. I dismiss this and tell it to start again, which it does with no problems.
  1. Vidalia then tells me it wants to authenticate to a running Vidalia process (from TBB) which I also dismiss.
  1. Vidalia's main screen says it is authenticating to Tor, while its Message Log indicates that it has actually successfully connected. The OS X onion in the top bar stays yellow, even though Tor is actually connected and functional.

So, all that said, once it gets past these obstacles, it does in fact run on a different port at the same time as TBB, which is extremely awesome and exciting.

I'm assigning this bug as a blocker because although Vidalia does work, it behaves too unpredictably for me to release packages with this version. I'm attaching some screenshots just to make it clear what I'm talking about.

Child Tickets

Attachments (3)

Screen shot 2011-08-15 at 9.58.39 PM.png (54.1 KB) - added by erinn 8 years ago.
Screen shot 2011-08-15 at 9.58.53 PM.png (160.8 KB) - added by erinn 8 years ago.
Screen shot 2011-08-15 at 9.59.15 PM.png (50.5 KB) - added by erinn 8 years ago.

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by erinn

Changed 8 years ago by erinn

Changed 8 years ago by erinn

comment:1 Changed 8 years ago by chiiph

It's really odd.
Have you specified DataDirectory=... under [Tor] in vidalia.conf? That's the directory it uses for telling tor to store the port.conf file with the controlport data.

There is a timing problem with the file that tor generates for the controlhost:controlport. Vidalia tries 5 times with a one second wait between each to read the file it told tor to write, if it isn't there after that time then it fails explaning shortly the situation.

Is there any /Users/erinn/.tor/ directory? can the tor process write there?

I think this is a configuration or may be directory permissions problem. I'm able to run without any problem on every platform, and mike didn't have any problems on Linux either. So with some luck this is a tiny detail thing.

Does this happen in Linux/Windows?

comment:2 Changed 8 years ago by erinn

Resolution: fixed
Status: newclosed

This is all fixed now, as of 0.2.14. Closing.

comment:3 Changed 2 years ago by teor

Severity: Normal

Set all tickets without a severity to "Normal"

Note: See TracTickets for help on using tickets.