Opened 9 years ago

Closed 9 years ago

#3768 closed defect (fixed)

pagead2.googlesyndication.com shouldn't be sent to https

Reported by: gene_wood Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Currently HTTPS Everywhere redirects this URL :

http://pagead2.googlesyndication.com/pagead/show_ads.js

to this URL :

https://pagead2.googlesyndication.com/pagead/show_ads.js

due to this rule :

https://gitweb.torproject.org/https-everywhere.git/blob/HEAD:/src/chrome/content/rules/GoogleServices.xml#l21
https://gitweb.torproject.org/https-everywhere.git/blob/HEAD:/src/chrome/content/rules/GoogleServices.xml#l74

Unfortunately the https page that it redirects to is served up by google with a certificate for "*.googleadservices.com , googleadservices.com"

This results in a certificate check failure and no ads being shown.

Please remove the rule that matches this URL since google isn't providing a valid cert.

To reproduce this problem :

  1. Running Firefox 6 with HTTPS Everywhere 1.0.1 installed browse to "http://pagead2.googlesyndication.com/paged/show_ads.js"
  2. You'll get back a "Untrusted Connection" error page from Firefox (see attachment of what it looks like)

Child Tickets

Attachments (1)

httpseverywhere-google-problem.png (63.0 KB) - added by gene_wood 9 years ago.
Screenshot of the firefox certificate check failure

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by gene_wood

Screenshot of the firefox certificate check failure

comment:1 Changed 9 years ago by pde

Status: newassigned

Are you still seeing this problem? I currently can't reproduce it.

comment:2 Changed 9 years ago by pde

Resolution: fixed
Status: assignedclosed

Marking as fixed. If this is still occurring, please reopen!

Note: See TracTickets for help on using tickets.