Opened 7 years ago

Closed 3 months ago

#3794 closed task (wontfix)

tor-chroot scripts

Reported by: ioerror Owned by: nickm
Priority: Medium Milestone: Tor: 0.3.4.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-client, bsd, tor-relay, chroot, review-group-34
Cc: nickm, sjmurdoch, arma Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I've written some scripts that help chroot a Tor - it's useful for chrooting a git build of Tor or for using the Tor binaries that are provided by Debian.

I'd like them to go into contrib/ so that they don't bit rot in a lonely repo; a lot of this was inspired by sjm's work on the topic but I had to cobble it together via email, wiki and other web servers.

How can I get the code into contrib?

Child Tickets

Attachments (1)

tor-chroot.tar.gz (4.5 KB) - added by ioerror 7 years ago.

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by ioerror

Attachment: tor-chroot.tar.gz added

comment:1 Changed 7 years ago by Sebastian

Component: Tor CheckTor Client

comment:2 Changed 7 years ago by nickm

Milestone: Tor: unspecified
Status: newneeds_review

arg, this should be in "needs_review"

comment:3 Changed 7 years ago by Sebastian

Resolution: duplicate
Status: needs_reviewclosed

seems to be a duplicate of #3782

comment:4 Changed 7 years ago by Sebastian

Resolution: duplicate
Status: closedreopened

eh, ugh. I meant to do it the other way around. I'm closing #3782 as a duplicate of this bug.

comment:5 Changed 7 years ago by Sebastian

Status: reopenedneeds_review

comment:6 Changed 6 years ago by nickm

Keywords: tor-client added

comment:7 Changed 6 years ago by nickm

Component: Tor ClientTor

comment:8 Changed 13 months ago by nickm

Cc: nickm sjmurdoch arma added; nickm sjmurdoch arma removed
Keywords: bsd tor-relay chroot added
Severity: Normal

comment:9 Changed 4 months ago by teor

Milestone: Tor: unspecifiedTor: 0.3.4.x-final

Move all needs_review tickets without a release to 0.3.4

comment:10 Changed 4 months ago by nickm

Keywords: review-group-34 added

comment:11 Changed 3 months ago by dgoulet

Resolution: wontfix
Status: needs_reviewclosed

Irrelevant after 7 years unfortunately. If you do have a newer patch for today's tor, open a new ticket.
Thanks!

Note: See TracTickets for help on using tickets.