Opened 7 years ago

Closed 5 years ago

#3823 closed defect (fixed)

Firefox google

Reported by: Jildsma Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords: firefox, google, refresh
Cc: tor@…, protoss1210@…, toshiba@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I use my awesome bar to search for something at Google, but whenever I reach the Google search results and click on a link, the link will redirect itself to the homepage (specific, to "http://www.google.nl/webhp?emsg=NCSR&noj=1&ei=Ex5YTqOUMIrn-gbw5MWRDA") instead of the url of the requested link. This happens with every search I try. It does not happen when HTPS-everywhere is turned off.

On-mouse-over gives the correct link. "Open link in new tab" will open the correct link (even in https when available).

I use OSX 10.6.8, FF 6.0 and HTTPS-everywhere 1.0.1

Child Tickets

Attachments (1)

liveheader.txt (9.6 KB) - added by Mrks83 6 years ago.
Live HTTP header capture (WIN7+FF7: search with search bar, click on hit...)

Download all attachments as: .zip

Change History (12)

comment:1 Changed 7 years ago by jabuci

Keywords: firefox google refresh added

I have the same problem. When I make a query on Google search and get a list of results, I need to click on a link twice. For the first click the search page is refreshed quickly. Then for the 2nd click I'm redirected. If HTTPS-everywhere is disabled, this problem is not present.

System: Ubuntu Linux 11.04, FF 6.0.2 (with 6.0.1 had the same problem), HTTPS-everywhere 1.0.1.

comment:2 Changed 7 years ago by hardcoded

Same Problem here with FF 6.0.2 and 7.0 on Win 7 64bit (all german versions).
I'm using TabMixPlus and NoScript (and some AddOns that *should* not mess around with tabs or URLs actively).

Strange: you can't even go back to the result page. It seems that the entry at the history is replaced.

comment:3 Changed 7 years ago by hardcoded

Cc: tor@… added

comment:4 Changed 7 years ago by pde

We received another report from one Chris E that looks to me like the same bug:

Hello, I am running Firefox7 and I noticed my google search results were not working at all. I would click on the links and nothing would happen. I ran FF in safe mode and it started working again. Turns out that this addon was having issues not only on this machine but on a friends machine as well. When they would click a link it would take them back to the google homepage with an error in the URL. I disabled all google-related redirects in https-everywhere and now it works fine.

comment:5 Changed 7 years ago by pde

Chris said he was using: Adblock Plus, Ghostery, Add This, BetterPrivacy, Chatzilla, CoolPreview, Download status-bar, Down-them-all, priceblink, and was located in the US.

He sent the following HTTPS Everywhere logs of the problem:

+http://www.google.com/url?sa=t&rct=j&q=dog&source=web&cd=1&ved=0CDsQFjAA&url=http%3A%2F%2Fen.wikipedia.org%2Fwiki%2FDog&ei=OEGFToDjAo3CsQKjyZDLDw&usg=AFQjCNGkEDcWzea4pSlurHhcuQfqFcp_pw&sig2=2tt0iNmg8Ca7SGYviLEj6w

HTTPS Everywhere: active rule GoogleServices in http://www.google.com/search?hl=en&source=hp&biw=1280&bih=651&q=dog&oq=dog&aq=f&aqi=g10&aql=&gs_sm=e&gs_upl=1134l1359l0l1458l3l2l0l0l0l0l133l250l0.2l2l0 ->
+http://www.google.com/search?hl=en&source=hp&biw=1280&bih=651&q=dog&oq=dog&aq=f&aqi=g10&aql=&gs_sm=e&gs_upl=1134l1359l0l1458l3l2l0l0l0l0l133l250l0.2l2l0 serial 240

HTTPS Everywhere: Redirection limit is 20

HTTPS Everywhere: Scheduling channel replacement for
+http://www.google.com/url?sa=t&rct=j&q=dog&source=web&cd=1&ved=0CDsQFjAA&url=http%3A%2F%2Fen.wikipedia.org%2Fwiki%2FDog&ei=OEGFToDjAo3CsQKjyZDLDw&usg=AFQjCNGkEDcWzea4pSlurHhcuQfqFcp_pw&sig2=2tt0iNmg8Ca7SGYviLEj6w

HTTPS Everywhere: Ran channel replacement for
+http://www.google.com/url?sa=t&rct=j&q=dog&source=web&cd=1&ved=0CDsQFjAA&url=http%3A%2F%2Fen.wikipedia.org%2Fwiki%2FDog&ei=OEGFToDjAo3CsQKjyZDLDw&usg=AFQjCNGkEDcWzea4pSlurHhcuQfqFcp_pw&sig2=2tt0iNmg8Ca7SGYviLEj6w

HTTPS Everywhere: Got http-on-modify-request:
+https://www.google.com/url?sa=t&rct=j&q=dog&source=web&cd=1&ved=0CDsQFjAA&url=http%3A%2F%2Fen.wikipedia.org%2Fwiki%2FDog&ei=OEGFToDjAo3CsQKjyZDLDw&usg=AFQjCNGkEDcWzea4pSlurHhcuQfqFcp_pw&sig2=2tt0iNmg8Ca7SGYviLEj6w

HTTPS Everywhere: Got http-on-examine-response @
+https://www.google.com/url?sa=t&rct=j&q=dog&source=web&cd=1&ved=0CDsQFjAA&url=http%3A%2F%2Fen.wikipedia.org%2Fwiki%2FDog&ei=OEGFToDjAo3CsQKjyZDLDw&usg=AFQjCNGkEDcWzea4pSlurHhcuQfqFcp_pw&sig2=2tt0iNmg8Ca7SGYviLEj6w

HTTPS Everywhere: Cookie hunting in
+https://www.google.com/url?sa=t&rct=j&q=dog&source=web&cd=1&ved=0CDsQFjAA&url=http%3A%2F%2Fen.wikipedia.org%2Fwiki%2FDog&ei=OEGFToDjAo3CsQKjyZDLDw&usg=AFQjCNGkEDcWzea4pSlurHhcuQfqFcp_pw&sig2=2tt0iNmg8Ca7SGYviLEj6w

Error: Permission denied to access property 'google'
Source File: https://www.google.com/url?sa=t&rct=j&q=dog&source=web&cd=1&ved=0CDsQFjAA&url=http%3A%2F%2Fen.wikipedia.org%2Fwiki%2FDog&ei=OEGFToDjAo3CsQKjyZDLDw&usg=AFQjCNGkEDcWzea4pSlurHhcuQfqFcp_pw&sig2=2tt0iNmg8Ca7SGYviLEj6w
Line: 1

HTTPS Everywhere: Got http-on-modify-request: https://phx-sync309.services.mozilla.com/1.1/25jdhzfi7s3mhva6r7wiawhi3iwlt2sj/info/collections

HTTPS Everywhere: exploded getting DOMWin for https://phx-sync309.services.mozilla.com/1.1/25jdhzfi7s3mhva6r7wiawhi3iwlt2sj/info/collections

HTTPS Everywhere: No applicable list rewriting https://phx-sync309.services.mozilla.com/1.1/25jdhzfi7s3mhva6r7wiawhi3iwlt2sj/info/collections

HTTPS Everywhere: Got http-on-examine-response @ https://phx-sync309.services.mozilla.com/1.1/25jdhzfi7s3mhva6r7wiawhi3iwlt2sj/info/collections

HTTPS Everywhere: Cookie hunting in https://phx-sync309.services.mozilla.com/1.1/25jdhzfi7s3mhva6r7wiawhi3iwlt2sj/info/collections

HTTPS Everywhere: exploded getting DOMWin for https://phx-sync309.services.mozilla.com/1.1/25jdhzfi7s3mhva6r7wiawhi3iwlt2sj/info/collections

HTTPS Everywhere: https://phx-sync309.services.mozilla.com/1.1/25jdhzfi7s3mhva6r7wiawhi3iwlt2sj/info/collections

comment:6 Changed 7 years ago by pde

For me, all of Chris's URLs seem to correctly redirect to the Wikipedia page for "Dog". I will try with a profile with his specific extensions installed.

comment:7 Changed 7 years ago by pde

Cc: protoss1210@… added

comment:8 Changed 7 years ago by pde

A profile with Chris E's set of extensions does seem awfully slow, but I still can't reproduce this bug.

For those of you who are seeing it, does it go away if you create a fresh profile with only HTTPS Everywhere installed?

comment:9 Changed 6 years ago by pde

Cc: toshiba@… added
Status: newaccepted

comment:10 Changed 6 years ago by pde

If anyone can email me a Live HTTP headers trace for this bug, that would be very helpful.

Changed 6 years ago by Mrks83

Attachment: liveheader.txt added

Live HTTP header capture (WIN7+FF7: search with search bar, click on hit...)

comment:11 Changed 5 years ago by schoen

Resolution: fixed
Status: acceptedclosed

This bug is from over a year and a half ago and refers to quite old versions of HTTPS Everywhere and Firefox. We suspect that this is now fixed in current versions! If not, please re-open this bug.

Note: See TracTickets for help on using tickets.