Opened 9 years ago

Closed 8 years ago

#3830 closed defect (fixed)

upgrade tor versions on deployed torperfs

Reported by: arma Owned by: ln5
Priority: Medium Milestone:
Component: Archived/Torperf Version:
Severity: Keywords:
Cc: linus@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

moria's torperf is running 0.2.2.22-alpha. I assume the other torperfs are similarly outdated.

Is there any reason to stick with that version, or should we upgrade them?

Should we consider some sort of automated upgrade plan, so we don't get into this position again later?

Child Tickets

Change History (4)

comment:1 Changed 9 years ago by ln5

Cc: linus@… added

comment:2 in reply to:  description Changed 9 years ago by karsten

Replying to arma:

moria's torperf is running 0.2.2.22-alpha. I assume the other torperfs are similarly outdated.

Is there any reason to stick with that version, or should we upgrade them?

Hmm? 0.2.2.22-alpha is still recommended for clients (and for servers), so why would we want to upgrade?

Are there performance changes between 0.2.2.22-alpha and 0.2.2.32? If so, we should upgrade and leave a note that we upgraded, or we'll later wonder why torperf results changed.

If you think we should upgrade, I'll do so on moria and ferrinii and will ask Linus to do so on siv.

Should we consider some sort of automated upgrade plan, so we don't get into this position again later?

An automatic upgrade would be bad, because tor's performance could change and we'd never know why that happened. But having some kind of notification that the tor version is not recommended anymore would be good. Not sure how to implement that easily though.

comment:3 Changed 8 years ago by karsten

Owner: changed from karsten to ln5
Status: newassigned

Upgraded moria and ferrinii to 0.2.2.35. Linus, please upgrade to 0.2.2.35 on siv, too. Assigning this ticket to you. Please close when you're done upgrading.

comment:4 Changed 8 years ago by ln5

Resolution: fixed
Status: assignedclosed

siv is now running 0.2.2.35.

Note: See TracTickets for help on using tickets.