Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#3833 closed defect (wontfix)

Maybe microdescriptor on/off toggle should require Tor restart?

Reported by: Sebastian Owned by:
Priority: Medium Milestone: Tor: 0.2.3.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Currently it is ok to change usemicrodescriptors via a config change. We should probably disallow that, as there are some indications that this doesn't work well: When debugging #3832, katmagic noticed that disabling microdescriptors didn't fix the issue, but disabling microdescriptors and then restarting did.

We could also try hard(er) to separate the two states. But I'd think that's hardly worth it, unless we need it for something else.

Happy to write the patch if a decision is made

Child Tickets

Change History (4)

comment:1 Changed 9 years ago by nickm

Status: newneeds_review

See branch bug3833 in my public repository

comment:2 Changed 9 years ago by nickm

Resolution: wontfix
Status: needs_reviewclosed

Actually, this is problematic. The issue is that if somebody says "UseMicrodescriptors auto", then whether they are using microdescriptors can change even if they never change the UseMicrodescriptors option. Since we allow (and really want to allow) transitions in ORPort, we need to allow transitions in whether people are using microdescriptors. And since that's the case, we might as well allow the UseMicrodescriptors option to change.

Please reopen if you disagree with my reasoning.

comment:3 Changed 8 years ago by nickm

Keywords: tor-client added

comment:4 Changed 8 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.