Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#3840 closed defect (duplicate)

Duplicate mark_for_close when running server with bufferevents

Reported by: stars Owned by: ioerror
Priority: Medium Milestone:
Component: Archived/Torouter Version: Tor: unspecified
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi,

I get a new error with Tor server running 0.2.3.2-alpha-dev with --Bufferevents enabled

[11:10:39] Tor Software Error - The Tor software encountered an internal bug. Please report the following error message to the Tor developers at bugs.torproject.org: "Bug: Duplicate call to connection_mark_for_close at directory.c:3561 (first at directory.c:3561)
"
commit c554a27a441083f85d8fafacdf39ddd7c376fbc7
Author: George Kadianakis <desnacked@…>
Date: Sat Aug 27 18:45:54 2011 +0200

Linux 2.6.38-10-generic #46~lucid1-Ubuntu SMP Wed Jul 6 18:41:04 UTC 2011 x86_64 GNU/Linux

best regards

SwissTorHelp

Child Tickets

Change History (2)

comment:1 Changed 6 years ago by nickm

Resolution: duplicate
Status: newclosed

This is a duplicate of #3814.

At this point, don't run Tor 0.2.3.2-alpha with bufferevent: the bufferevents code is changing pretty fast, almost every day, as I try to shake bugs out of it. I'd suggest that you either run without bufferevents and wait for 0.2.3.3-alpha, or try to track git master.

comment:2 Changed 6 years ago by stars

Hi nickm,

Yep, i track "master branch" oft.. Thanksfor your answer

Note: See TracTickets for help on using tickets.