Opened 6 years ago

Closed 6 years ago

#3843 closed defect (fixed)

Linux TBB: Vidalia + "controlport auto" = missing port.conf file

Reported by: arma Owned by: erinn
Priority: Medium Milestone: Vidalia: 0.2.15
Component: Archived/Vidalia Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I started Linux TBB 1.1.14-dev 64-bit. It worked fine.

I went to Vidalia's advanced window, and clicked "Configure ControlPort automatically". Then I exited TBB and restarted it.

Vidalia pops up a complaint window after a few seconds:

Vidalia can't find out how to talk to Tor because it can't access this file: /port.conf

Here's the last error message:
No such file or directory

I see that we just closed #2264 ("dynamically choose available Tor ports in TBB"), so I figured I should report this.

Child Tickets

Change History (14)

comment:1 Changed 6 years ago by arma

Vidalia's message window for Tor includes:

[Warning] Couldn't open "/port.conf.tmp" (/port.conf) for writing: Permission denied
[Warning] Writing /port.conf failed: Permission denied

It looks like Tor is trying to write the file to the wrong place.

I see "ControlPortWriteToFile /port.conf" as part of the Tor commandline that Vidalia launched.

comment:2 Changed 6 years ago by erinn

This isn't supposed to work in the FF 3.6 TBBs, because they are missing several config file options (ControlPort auto and SocksPort auto in the torrc, and AutoControl=True and DataDirectory=./Data/Tor in vidalia.conf)and don't use Torbutton 1.4.1. It is on by default in the latest FF6 bundles.

comment:3 Changed 6 years ago by rransom

Resolution: wontfix
Status: newclosed

Closing this ticket as 'wontfix', because the Firefox 3.6 TBBs are supposed to die soon.

comment:4 Changed 6 years ago by erinn

Component: Tor bundles/installationVidalia
Resolution: wontfix
Status: closedreopened

I'm reopening this because although it is 'wontfix' for TBB, I think it is probably still a bug, either with Tor or Vidalia. Irrespective of whether his Firefox could handle it, if you tell Vidalia you want automatic control port, and it fails to do that for you because Tor(?) can't write the file, that is a bug. I just don't know whether it's a Tor or Vidalia bug.

So, I'm going to assign it to Vidalia first, and if Tomás decides it's not his bug, he can reassign it to Tor.

comment:5 Changed 6 years ago by arma

arma     30700  7.2  0.5  42604 20460 pts/3    S+   07:39   0:00 ./App/tor -f ./Data/Tor/torrc ControlPort auto SocksPort auto ControlPortWriteToFile /port.conf HashedControlPassword 16:21EE...

is my ps output.

It's clearly not a Tor issue -- Tor is getting handed a specific path, and is trying to use it.

comment:6 Changed 6 years ago by chiiph

This should be a Vidalia bug, since it shouldn't let the user get away with configuring AutoPort without setting a DataDirectory.

comment:7 Changed 6 years ago by Sebastian

Here's the issue: TBB doesn't set a DataDirectory in vidalia.conf, so Tor doesn't get a DataDirectory. It defaults to $HOME/.tor, which is cool generally.

But now the ControlPortWriteToFile is implemented (inside Vidalia) as $DataDirectoryTADIR/port.conf, but $DataDirectory is empty - so that becomes /port.conf. The issue is that Vidalia passes an absolute path that is outside of TBB.

comment:8 Changed 6 years ago by erinn

Milestone: Vidalia: 0.2.15

Assigning to the Vidalia 0.2.15 milestone I just created, which has a due date of Sept 10 2011, when we will be releasing new TBBs.

comment:9 Changed 6 years ago by chiiph

Status: reopenedneeds_review

I've added a branch chiiph/bug3843_checkauto with fix for this.

The logic behind it is the following:
When vidalia is going to start tor:

if autcontrol==true && datadirectory==false: 
   disable autocontrol and start tor normally.

In the Advanced Settings panel:
1)

if the user tries to save autocontrol=true and datadirectory="":
   display a message informing the user that she must fix that.

2)

if the tor version is < 0.2.2.16: 
   autocontrol=false, and hide the autocontrol checkbox.

comment:10 Changed 6 years ago by chiiph

It's 0.2.2.26 instead of 0.2.2.16

comment:11 Changed 6 years ago by erinn

Just wanted to note that I have added DataDirectory to all of the 3.6 TBBs, so when we release tomorrow (or whenever we get our new Firefoxes), nobody will be bitten by this accidentally.

comment:12 Changed 6 years ago by rransom

Can this be closed now?

comment:13 Changed 6 years ago by arma

Is chiiph's branch in any vidalia git? (I sure wish we had more people to review vidalia patches...)

comment:14 Changed 6 years ago by chiiph

Resolution: fixed
Status: needs_reviewclosed

This was merged and released with 0.2.15.

Note: See TracTickets for help on using tickets.