Opened 6 years ago

Closed 14 months ago

#3870 closed defect (wontfix)

Tor 0.2.3.x with bufferevents enabled does not report log messages to the control port

Reported by: rransom Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Keywords: bufferevents tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I started Vidalia 0.2.12 and connected it to my already-running Tor client (0.2.3.2-alpha-dev with bufferevents enabled, built by nickm on 2011-08-24), opened the 'Advanced' tab of the 'Message Log', enabled info-level log messages, and clicked 'Save Settings'. I see no log messages at all in the Message Log window, even though Tor's log file contains several notice-level messages sent after Vidalia connected to Tor (both before and after I enabled info-level messages in Vidalia's Message Log). The circuit list in the 'Network Map' window is working correctly.

Child Tickets

Change History (9)

comment:1 Changed 6 years ago by chiiph

Can you reproduce this with a 0.2.2.X tor? I haven't tried the bufferevents alpha, but I can't reproduce with 0.2.2.32.

comment:2 Changed 6 years ago by rransom

Component: VidaliaTor Client
Owner: chiiph deleted
Status: newassigned
Summary: Vidalia 0.2.12 Advanced Message Log does not workTor 0.2.3.x with bufferevents enabled does not report log messages to the control port

Then it's a Tor bug.

I was running this Tor instance as a Windows service, but I would be very surprised if that made any difference.

comment:3 Changed 6 years ago by nickm

Milestone: Tor: 0.2.3.x-final
Priority: majornormal

comment:4 Changed 6 years ago by nickm

Keywords: bufferevents added

comment:5 Changed 6 years ago by nickm

Milestone: Tor: 0.2.3.x-finalTor: 0.2.4.x-final

comment:6 Changed 5 years ago by nickm

Keywords: tor-client added

comment:7 Changed 5 years ago by nickm

Component: Tor ClientTor

comment:8 Changed 5 years ago by nickm

Milestone: Tor: 0.2.4.x-finalTor: unspecified

comment:9 Changed 14 months ago by nickm

Resolution: wontfix
Status: assignedclosed

The bufferevents code and corresponding build options have been removed in 0.2.9.2-alpha

Note: See TracTickets for help on using tickets.