Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#3879 closed defect (fixed)

Framed sites broken (yopmail, gmane, gmaps, etc)

Reported by: cypherpunks Owned by: mikeperry
Priority: Medium Milestone:
Component: TorBrowserButton Version: Torbutton: 1.4.0
Severity: Keywords: MikePerryIterationFires20110911
Cc: Actual Points: 1
Parent ID: Points: 1
Reviewer: Sponsor:

Description

Since I've updated to Iceweasel 6.0-4 and subsequently 7.0~b2-1 ("b2" stands for "beta 2") the Torbutton add-on (1.4.1) is breaking the frame system. Reproducible with (e.g.) [0] (other pages with frames, I'm using, are behind logins and thus no good public examples ;)). Instead of loading the e-mail's content in the lower frame, a new tab/window (depending on your settings) is opened. Disabling Torbutton works around this bug.

Iceweasel 6.0-2 was the last known working version. Iceweasel is the same as Firefox, just the name was changed due to Mozilla making much ado about nothing. The Debian revisions (e.g. "-2" or "-4") indicate updates to the packaging and sometimes the inclusion of upstream commits/patches, for details about what changed, see [1].

[0] <http://news.gmane.org/gmane.comp.video.mesa3d.devel>
[1] <http://packages.debian.org/changelogs/pool/main/i/iceweasel/current/changelog> and <http://packages.debian.org/changelogs/pool/main/i/iceweasel/iceweasel_6.0-4/changelog>

Child Tickets

Attachments (1)

torbutton-1.4.1+3879.xpi (737.3 KB) - added by mikeperry 6 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 6 years ago by cypherpunks

Oh, I forgot another example to test the breakage: Google Maps. Just enter any address and run the search. A new tab/window will open, but no map is seen anywhere, not even the default starting map on opening the maps.google.* page.

comment:2 Changed 6 years ago by mikeperry

Keywords: MikePerryIterationFires20110911 added

Possible dup of #3858. Will look into it.

Changed 6 years ago by mikeperry

Attachment: torbutton-1.4.1+3879.xpi added

comment:3 Changed 6 years ago by mikeperry

Actual Points: 1
Points: 1
Resolution: fixed
Status: newclosed

The attached XPI should fix it. Let me know if you have any issues.

comment:4 Changed 6 years ago by mikeperry

Summary: Frames broken in Iceweasel (aka Firefox) 6.0-4+Framed sites broken (yopmail, gmane, gmaps, etc)

comment:5 Changed 6 years ago by mikeperry

Component: TorbuttonTorBrowserButton

comment:6 in reply to:  3 Changed 6 years ago by cypherpunks

Replying to mikeperry:

The attached XPI should fix it. Let me know if you have any issues.

WFM, thanks.

comment:7 Changed 6 years ago by cypherpunks

Resolution: fixed
Status: closedreopened

And it is back again (with e.g. GMaps). I'm on Iceweasel 7.0~b6 and I'm using TorButton 1.4.3; was the fix lost somewhere? Not applied?

comment:8 Changed 6 years ago by cypherpunks

Keywords: MikePerryIterationFires20110911 removed

Ok, it might be a different bug, not sure, though. Anyway Gmane is working for example, while Google Maps is not (if you enter something in the search box and hit the button, a new tab is opened with a input field, but the map isn't updated; basically the same as before this bug was fixed).

Let me now if you need more information and/or whether I should report this as a new bug.

comment:9 Changed 6 years ago by mikeperry

Keywords: MikePerryIterationFires20110911 added
Resolution: fixed
Status: reopenedclosed

Navigating to maps.google.com and typing "something" into the search box and then clicking on the search button works fine for me in both TBB and FF7 + Torbutton 1.4.3.

You perhaps have a conflict. Disable your other addons and test again.

Also, please file a new bug if/when you discover the cause, don't use this one. It appears to be a new (or at least different) issue.

comment:10 Changed 6 years ago by mikeperry

Minor correction: The FF7 I tested was an FF7 build with our TBB patches applied.

If this bug still applies to vanilla FF7 without patches, it needs a new bug filed under the Torbutton component (which is currently unmaintained).

Note: See TracTickets for help on using tickets.