Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#3915 closed defect (not a bug)

Control listener on /var/run/tor/control

Reported by: toruser32 Owned by:
Priority: Medium Milestone: Tor: 0.2.3.x-final
Component: Core Tor/Tor Version: Tor: 0.2.2.32
Severity: Keywords: tor-client
Cc: weasel Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

why does tor open a control listener on /var/run/tor/control? This looks like a bug to me.

log:
sudo /usr/sbin/tor -f /etc/tor/my-tor1rc
Sep 02 16:27:07.281 [notice] Tor v0.2.2.32 (git-84a279ff87e5bfea). This is experimental software. Do not rely on it for strong anonymity. (Running on Linux x86_64)
Sep 02 16:27:07.282 [notice] Initialized libevent version 1.4.13-stable using method epoll. Good.
Sep 02 16:27:07.282 [notice] Opening Transparent pf/netfilter listener on 127.0.0.1:9041
Sep 02 16:27:07.282 [notice] Opening DNS listener on 127.0.0.1:9031
Sep 02 16:27:07.282 [notice] Opening Control listener on 127.0.0.1:9051
Sep 02 16:27:07.282 [notice] Opening Control listener on /var/run/tor/control
Sep 02 16:27:07.283 [notice] Opening Control listener on /var/run/tor/my-tor1-control-socket

torrc:

ControlSocket /var/run/tor/my-tor1-control-socket
ControlPort 9051
CookieAuthentication 1
CookieAuthFile /tmp/my-tor1-control-auth-cookie
ClientOnly 1
TransPort 9041
DNSPort 9031
SocksPort 0
AutomapHostsOnResolve 1
VirtualAddrNetwork 10.0.0.0/8
Log notice file /var/log/tor/my-tor1-log
PidFile /var/run/tor/my-tor1.pid
DataDirectory /var/lib/tor/my-tor-1

Child Tickets

Change History (4)

comment:1 Changed 9 years ago by arma

Cc: weasel added

The debian Tor package changes the default for the controlsocket config option. If you set one also, you end up with two.

See also #3774 for the same issue.

comment:2 Changed 8 years ago by weasel

Resolution: not a bug
Status: newclosed

nothing to see here, move along.

comment:3 Changed 8 years ago by nickm

Keywords: tor-client added

comment:4 Changed 8 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.