Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#3919 closed defect (not a bug)

38.229.70.47 PSI FAKE FILES ?

Reported by: falcontor Owned by:
Priority: Low Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

i use a software called peerguard on my linux server to block somme IP range and when i lunch tor i see droped IP:

dropped src: 82.216.x.x dst: 38.229.70.47 (PSI FAKE FILES BLOCK 13)

who is for 38.229.70.47 is torproxy08.teamcymru.net

can you confirme 38.229.70.47 is not a fake so i can remove it from
peerguard config ? thank

and i get also:

Sep 03 22:06:12.036 [notice] Tor 0.2.1.30 opening new log file.
Sep 03 22:06:12.075 [notice] Parsing GEOIP file.
Sep 03 22:06:12.381 [notice] OpenSSL OpenSSL 0.9.8h 28 May 2008 [90808f] looks like it's older than 0.9.8l, but some vendors have backported 0.9.8l's renegotiation code to earlier versions, and some have backported the code from 0.9.8m or 0.9.8n. I'll set both SSL3_FLAGS and SSL_OP just to be safe.
Sep 03 22:06:12.479 [notice] Your Tor server's identity key fingerprint is 'Falcontor 02E2CF2C2AD9B09629D05791B7D739160D75C68F'
Sep 03 22:06:18.573 [notice] I learned some more directory information, but not enough to build a circuit: We have no network-status consensus.
Sep 03 22:06:24.740 [notice] Bootstrapped 45%: Asking for relay descriptors.
Sep 03 22:06:24.740 [notice] I learned some more directory information, but not enough to build a circuit: We have only 0/2623 usable descriptors.
Sep 03 22:06:25.087 [notice] Bootstrapped 54%: Loading relay descriptors.
Sep 03 22:06:25.087 [notice] I learned some more directory information, but not enough to build a circuit: We have only 96/2622 usable descriptors.
Sep 03 22:06:25.238 [notice] Bootstrapped 58%: Loading relay descriptors.
Sep 03 22:06:25.239 [notice] I learned some more directory information, but not enough to build a circuit: We have only 191/2620 usable descriptors.
Sep 03 22:06:25.270 [notice] Bootstrapped 62%: Loading relay descriptors.
Sep 03 22:06:25.270 [notice] I learned some more directory information, but not enough to build a circuit: We have only 287/2620 usable descriptors.
Sep 03 22:06:25.309 [notice] Bootstrapped 66%: Loading relay descriptors.
Sep 03 22:06:25.309 [notice] I learned some more directory information, but not enough to build a circuit: We have only 383/2620 usable descriptors.
Sep 03 22:06:25.340 [notice] Bootstrapped 71%: Loading relay descriptors.
Sep 03 22:06:25.340 [notice] I learned some more directory information, but not enough to build a circuit: We have only 479/2620 usable descriptors.
Sep 03 22:06:25.403 [notice] Bootstrapped 74%: Loading relay descriptors.
Sep 03 22:06:25.403 [notice] I learned some more directory information, but not enough to build a circuit: We have only 543/2620 usable descriptors.
Sep 03 22:06:25.444 [notice] Bootstrapped 78%: Loading relay descriptors.
Sep 03 22:06:25.444 [notice] I learned some more directory information, but not enough to build a circuit: We have only 639/2620 usable descriptors.
Sep 03 22:06:25.524 [notice] We now have enough directory information to build circuits.
Sep 03 22:06:25.524 [notice] Bootstrapped 80%: Connecting to the Tor network.
Sep 03 22:06:25.672 [notice] Bootstrapped 85%: Finishing handshake with first hop.
Sep 03 22:06:26.429 [notice] Bootstrapped 90%: Establishing a Tor circuit.
Sep 03 22:06:31.424 [notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Sep 03 22:06:31.424 [notice] Bootstrapped 100%: Done.
Sep 03 22:06:31.424 [notice] Now checking whether ORPort 82.216.145.52:9001 and DirPort 82.216.145.x:9030 are reachable... (this may take up to 20 minutes -- look for log messages indicating success)
Sep 03 22:26:18.217 [warn] Your server (82.216.145.x:9001) has not managed to confirm that its ORPort is reachable. Please check your firewalls, ports, address, /etc/hosts file, etc.
Sep 03 22:26:18.218 [warn] Your server (82.216.145.x:9030) has not managed to confirm that its DirPort is reachable. Please check your firewalls, ports, address, /etc/hosts file, etc.

i think i will install the lastest tor version

Child Tickets

Change History (4)

comment:1 in reply to:  description Changed 8 years ago by arma

Component: - Select a componentTor Relay
Type: projectdefect

Replying to falcontor:

i use a software called peerguard on my linux server to block somme IP range and when i lunch tor i see droped IP:

dropped src: 82.216.x.x dst: 38.229.70.47 (PSI FAKE FILES BLOCK 13)

who is for 38.229.70.47 is torproxy08.teamcymru.net

can you confirme 38.229.70.47 is not a fake so i can remove it from
peerguard config ? thank

That IP address is a normal Tor relay. There's nothing "fake" about it.

More generally, if you want to run peerguard while being a Tor client, be my guest. It will hurt your Tor performance, but probably not that much.

On the other hand, please don't run peerguard while being a Tor *relay*. You will be hurting performance for all the other users, because your relay will mysteriously not be able to reach some of the other relays. See also https://trac.torproject.org/projects/tor/wiki/doc/TorFAQ#DoIhavetoopenalltheseoutboundportsonmyfirewall

Sep 03 22:06:31.424 [notice] Now checking whether ORPort 82.216.145.52:9001 and DirPort 82.216.145.x:9030 are reachable... (this may take up to 20 minutes -- look for log messages indicating success)
Sep 03 22:26:18.217 [warn] Your server (82.216.145.x:9001) has not managed to confirm that its ORPort is reachable. Please check your firewalls, ports, address, /etc/hosts file, etc.
Sep 03 22:26:18.218 [warn] Your server (82.216.145.x:9030) has not managed to confirm that its DirPort is reachable. Please check your firewalls, ports, address, /etc/hosts file, etc.

i think i will install the lastest tor version

Upgrading to the latest stable version of Tor is a fine idea, but I think the problem here is that you didn't set up port forwarding correctly on your router.

comment:2 Changed 8 years ago by nickm

Milestone: Tor: unspecified
Resolution: not a bug
Status: newclosed

comment:3 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:4 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.