Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#3933 closed defect (fixed)

app.update.auto is getting changed to true

Reported by: erinn Owned by: mikeperry
Priority: High Milestone: TorBrowserBundle 2.2.x-stable
Component: TorBrowserButton Version:
Severity: Keywords: MikePerryIterationFires20110911, tbb-2.2.32-4
Cc: Actual Points: 1
Parent ID: Points: 1
Reviewer: Sponsor:

Description

We currently ship a prefs.js in TBB that disallows auto updating of Firefox, but for some reason this is being changed from false to true, either at run time or some other time. I think it is possible (likely) that either one of the other prefs for updating we set to true is causing this other one to be overridden, or we are missing some kind of build option (or adding one inadvertently) that is causing Firefox itself to override/overwrite this pref. I will investigate and fix this before our September 10th release.

Child Tickets

Change History (6)

comment:1 Changed 8 years ago by mikeperry

Summary: app.update.auto is getting changed to true in prefs.jsSeveral pref values are getting changed mysteriously from values in prefs.js

My guess is that it could be as simple as us using user_prefs() instead of prefs() in our prefs.js file.

user_prefs() sets a user value, which may cause Firefox to emit observer events for each preference we change in this way. If one of them has an exception because the observer for that pref is buggy and/or tries to touch some not-yet-initialized piece of Firefox at startup, that could easily cause the behavior we see here.

Also, this issue is not just limited to app.update.auto. People have reported issues with formfill options as well.

comment:2 Changed 8 years ago by mikeperry

Component: Tor bundles/installationTorBrowserButton
Keywords: MikePerryIterationFires20110911 added
Owner: changed from erinn to mikeperry
Status: newassigned
Summary: Several pref values are getting changed mysteriously from values in prefs.jsapp.update.auto is getting changed to true

Scratch my previous comment. We've discovered that the app.update.auto issue is specifically due to a regression caused by #2338.

I filed #3944 for the user_prefs() issue.

comment:3 Changed 8 years ago by mikeperry

Actual Points: 1
Points: 1
Resolution: fixed
Status: assignedclosed

Fixed in origin/master. Will appear in Torbutton 1.4.3.

comment:4 Changed 8 years ago by erinn

Parent ID: #3969

comment:5 Changed 8 years ago by erinn

Keywords: 2.2.32-4 added
Parent ID: #3969

comment:6 Changed 8 years ago by erinn

Keywords: tbb-2.2.32-4 added; 2.2.32-4 removed
Note: See TracTickets for help on using tickets.