Opened 8 years ago

Closed 7 years ago

#3941 closed defect (fixed)

Windows users + firewalls having trouble with automatic port selection

Reported by: erinn Owned by: erinn
Priority: High Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We've been seeing a lot of complaints from Windows users with firewalls who experience apparently random behavior in whether their tor in TBB connects successfully. It gets to Bootstrapped 100%: Done and then doesn't do anything else.

After some minor experimentation -- having them turn off (or uninstall) their firewall, and having one revert the TBB settings back to pre-auto days -- I think Windows and firewalls simply can't handle the automatic port selection very well. Tor will connect to an open port (I think) and then not actually be able to send traffic. Since it doesn't connect to the network, but doesn't obviously error, users just wait and get frustrated.

velope had an idea on IRC that there could be a client version of reachability testing for local ports.

Child Tickets

Change History (6)

comment:1 Changed 8 years ago by nickm

Can you explain more about what works and what doesn't here? Is it 'ControlPort auto' that is at issue? 'SocksPort auto'? Clients shouldn't be opening other ports IIUC -- or is this for relays?

comment:2 Changed 8 years ago by rransom

I have seen two reports of 'TBB doesn't work' from Comodo Firewall users today, and velope said that he had seen other reports that TBB didn't work with Comodo Firewall running.

comment:3 Changed 8 years ago by rransom

16:36 < velope> separately, it appears comodo blocks software launched from usb from opening any port.

comment:4 in reply to:  description Changed 8 years ago by arma

Replying to erinn:

velope had an idea on IRC that there could be a client version of reachability testing for local ports.

Fleshed out as #3943.

comment:5 Changed 8 years ago by arma

Component: Tor ClientTor bundles/installation
Owner: set to erinn
Version: Tor: 0.2.2.32

Switching this to a 'bundles' bug. I opened #3948 for a fix that could be done on the Tor side, and that I think would also resolve this ticket.

comment:6 Changed 7 years ago by Sebastian

Resolution: fixed
Status: newclosed

This is fixed in the windows bundles as the auto port feature is disabled there now.

Note: See TracTickets for help on using tickets.