Opened 8 years ago

Closed 7 years ago

#3952 closed defect (fixed)

Connection Refused By Peer

Reported by: jakelikessnakes Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: tbb-2.2.32-4
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Vidalia and Tor were working fine for the past two weeks; suddenly today I got the error: "Vidalia was unable to connect to Tor. (Connection refused by peer.)

When I open the log, I get no warnings. Full log shows:

Sep 07 19:27:18.146 [Notice] Tor v0.2.2.32 (git-877e17749725ab88). This is experimental software. Do not rely on it for strong anonymity. (Running on Windows 7 Service Pack 1 [workstation])

Sep 07 19:27:18.146 [Notice] Initialized libevent version 2.0.14-stable using method win32. Good.

Sep 07 19:27:18.146 [Notice] Opening Socks listener on 127.0.0.1:0

Sep 07 19:27:18.146 [Notice] Socks listener listening on port 52111.

Sep 07 19:27:18.146 [Notice] Opening Control listener on 127.0.0.1:0

Sep 07 19:27:18.146 [Notice] Control listener listening on port 52112.

Sep 07 19:27:18.259 [Notice] Based on 173 circuit times, it looks like we don't need to wait so long for circuits to finish. We will now assume a circuit is too slow to use after waiting 7 seconds.

Sep 07 19:27:18.259 [Notice] Parsing GEOIP file .\Data\Tor\geoip.

Sep 07 19:27:20.333 [Notice] OpenSSL OpenSSL 1.0.0d 8 Feb 2011
looks like version 0.9.8m or later; I will try SSL_OP to enable renegotiation

Sep 07 19:27:20.987 [Notice] We now have enough directory information to build circuits.

Sep 07 19:27:20.988 [Notice] Bootstrapped 80%: Connecting to the Tor network.

Sep 07 19:27:22.124 [Notice] Bootstrapped 85%: Finishing handshake with first hop.

Sep 07 19:27:23.001 [Notice] Bootstrapped 90%: Establishing a Tor circuit.

Sep 07 19:27:24.094 [Notice] Tor has successfully opened a circuit. Looks like client functionality is working.

Sep 07 19:27:24.094 [Notice] Bootstrapped 100%: Done.

I made no changes to my settings or network configuration, no changes or updates to my OS (Running Windows 7x64) or software/hardware configuration. Basically, from a user-perspective, I made NO changes.

Child Tickets

Change History (4)

comment:1 Changed 8 years ago by arma

Component: - Select a componentTor bundles/installation
Owner: set to erinn

Sounds like an instance of #3941. If that's true, sit tight and there should be another TBB out soon.

But as for your "no changes", I'm guessing you upgraded your TBB recently?

Do you happen to use a Comodo firewall?

comment:2 Changed 8 years ago by erinn

I have just reproduced this on OSX as well. I'm not 100% sure how to reproduce it deliberately, but I'll post details when I do.

jakelikessnakes, can you try this package in the meanwhile:
https://archive.torproject.org/tor-package-archive/technology-preview/tor-browser-2.2.32-UNOFFICIAL-1_en-US.exe
https://archive.torproject.org/tor-package-archive/technology-preview/tor-browser-2.2.32-UNOFFICIAL-1_en-US.exe.asc

It has two configuration file changes that stop TBB from trying to automatically select a port and should fix your problem until we get new ones out (which is going to be quite soon, but still).

comment:3 Changed 8 years ago by erinn

Keywords: tbb-2.2.32-4 added

comment:4 Changed 7 years ago by Sebastian

Resolution: fixed
Status: newclosed

assuming this is fixed, please reopen if it isn't

Note: See TracTickets for help on using tickets.