Opened 8 years ago

Closed 8 years ago

#3955 closed defect (fixed)

Torbutton addon for firefox makes gmail buggy

Reported by: nblouveton Owned by: mikeperry
Priority: Medium Milestone:
Component: Applications/Torbutton Version: Torbutton: 1.4.0
Severity: Keywords: MikePerryIteration20111009
Cc: Tim.timmerman@…, rransom Actual Points: 1
Parent ID: Points: 2
Reviewer: Sponsor:

Description

Hi !

Torbutton add-on for firefox induces server error 103 when an email is sent with an attachment in gmail.

Issue happened with :

Firefox 6.0.1 and 8.0a2 on ubuntu 11.04

Torbutton 1.4.2

Mail sending without an attachment is ok, but when an attachment is added mail sending fails with error code 103.

Problem is solved disabling torbutton extension.

Regards,

Nicolas

Child Tickets

Change History (13)

comment:1 Changed 8 years ago by arma

Component: - Select a componentTorbutton
Owner: set to mikeperry

Can you confirm that the same behavior happens in Tor Browser Bundle too?

https://www.torproject.org/download/download#linux

comment:2 Changed 8 years ago by TimT

Cc: Tim.timmerman@… added

Problem also confirmed with torbutton 1.4.3; Firefox 6.0.2 (Mozilla Firefox for Ubuntu canonical -1.0)

Just downloaded the Tor Browser Bundle, and confirmed the bug there as well

"Oops... A server error occurred and your email was not saved (#103)
(This happens on Save action; message says "not send" for send button.)

comment:3 Changed 8 years ago by mikeperry

Keywords: MikePerryIterationFires20110925 added

comment:4 Changed 8 years ago by mikeperry

Are we sure that this is a torbutton error?

Hint: If it doesn't happen *every* time you do something, it probably isn't a Torbutton problem, and could be a problem at your Tor exit, or elsewhere.

comment:5 in reply to:  4 ; Changed 8 years ago by rransom

Replying to mikeperry:

Are we sure that this is a torbutton error?

Hint: If it doesn't happen *every* time you do something, it probably isn't a Torbutton problem, and could be a problem at your Tor exit, or elsewhere.

Yes.

comment:6 in reply to:  5 Changed 8 years ago by mikeperry

Replying to rransom:

Replying to mikeperry:

Are we sure that this is a torbutton error?

Hint: If it doesn't happen *every* time you do something, it probably isn't a Torbutton problem, and could be a problem at your Tor exit, or elsewhere.

Yes.

Yes what?

comment:7 Changed 8 years ago by rransom

I received a ‘Server error’ page every time I tried to follow the link to read a ‘whole message’ which GMail had truncated.

I was able to successfully send messages with multiple attachments recently, using the ‘basic HTML’ interface.

On second thought, this is sounding like it's not a Torbutton problem (or a problem that Torbutton can fix).

comment:8 Changed 8 years ago by mikeperry

Yeah, it could be a script timeout or other weird interaction with their AJAX interface.

We should keep an eye on this anyways (esp if it only manifests in a certain version of Torbutton), since it might be aggravated by something we did.

Other option is to see if tweaking various torbutton options makes it go away.

comment:9 Changed 8 years ago by mikeperry

<mikeperry> rransom: so you're saying the 'whole message' link was broken and now it is not in the basic html interface?
<ransom
> The 'whole message' link was broken every time I tried it.

comment:10 Changed 8 years ago by mikeperry

Keywords: MikePerryIteration20111009 added; MikePerryIterationFires20110925 removed
Points: 2

comment:11 Changed 8 years ago by mikeperry

The .xpi in #4145 seems to fix this issue. I use the AJAX interface of gmail, which seems to work fine for sending large mail attachments now.

I then switched to the basic version, and I could not find a 'whole message' link. There is an 'original message' link, and that properly displays the whole message w/ headers, but it does so in a new tab. Is this normal?

The xpi is built from c725da03ecc54934eb52582a785ccedd4c012b4b of torbutton.git origin/master.

comment:12 Changed 8 years ago by mikeperry

Cc: rransom added

Is anyone still seeing this with the new xpi? If not, I am going to close.

comment:13 Changed 8 years ago by mikeperry

Actual Points: 1
Resolution: fixed
Status: newclosed

Assuming this is fixed. Fix will appear in 1.4.4 this weekend.

Note: See TracTickets for help on using tickets.