Opened 8 years ago

Closed 8 years ago

#3981 closed defect (duplicate)

Connection Refused By Peer

Reported by: jakelikessnakes Owned by: mikeperry
Priority: Very High Milestone:
Component: Firefox Patch Issues Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Starting last week, with no changes to my hardware, software or network settings, I can no longer connect to the Tor network; connection refused by peer.

My log shows no anomalies. See below:

Sep 10 13:18:59.287 [Notice] Tor v0.2.2.32 (git-877e17749725ab88). This is experimental software. Do not rely on it for strong anonymity. (Running on Windows 7 Service Pack 1 [workstation])
Sep 10 13:18:59.287 [Notice] Initialized libevent version 2.0.14-stable using method win32. Good.
Sep 10 13:18:59.287 [Notice] Opening Socks listener on 127.0.0.1:0
Sep 10 13:18:59.287 [Notice] Socks listener listening on port 53974.
Sep 10 13:18:59.287 [Notice] Opening Control listener on 127.0.0.1:0
Sep 10 13:18:59.287 [Notice] Control listener listening on port 53975.
Sep 10 13:18:59.393 [Notice] Based on 173 circuit times, it looks like we don't need to wait so long for circuits to finish. We will now assume a circuit is too slow to use after waiting 7 seconds.
Sep 10 13:18:59.393 [Notice] Parsing GEOIP file .\Data\Tor\geoip.
Sep 10 13:19:01.577 [Notice] OpenSSL OpenSSL 1.0.0d 8 Feb 2011 looks like version 0.9.8m or later; I will try SSL_OP to enable renegotiation
Sep 10 13:19:04.775 [Notice] I learned some more directory information, but not enough to build a circuit: We have no recent network-status consensus.
Sep 10 13:19:05.870 [Notice] Bootstrapped 5%: Connecting to directory server.
Sep 10 13:19:06.086 [Notice] Bootstrapped 10%: Finishing handshake with directory server.
Sep 10 13:19:07.179 [Notice] Bootstrapped 15%: Establishing an encrypted directory connection.
Sep 10 13:19:07.613 [Notice] Bootstrapped 20%: Asking for networkstatus consensus.
Sep 10 13:19:07.831 [Notice] Bootstrapped 25%: Loading networkstatus consensus.
Sep 10 13:19:10.126 [Notice] Bootstrapped 45%: Asking for relay descriptors.
Sep 10 13:19:10.126 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 0/2364 usable descriptors.
Sep 10 13:19:11.546 [Notice] Bootstrapped 50%: Loading relay descriptors.
Sep 10 13:19:12.639 [Notice] Bootstrapped 54%: Loading relay descriptors.
Sep 10 13:19:12.639 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 87/2364 usable descriptors.
Sep 10 13:19:12.968 [Notice] Bootstrapped 58%: Loading relay descriptors.
Sep 10 13:19:12.968 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 183/2364 usable descriptors.
Sep 10 13:19:13.295 [Notice] Bootstrapped 63%: Loading relay descriptors.
Sep 10 13:19:13.295 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 279/2364 usable descriptors.
Sep 10 13:19:13.622 [Notice] Bootstrapped 67%: Loading relay descriptors.
Sep 10 13:19:13.622 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 364/2364 usable descriptors.
Sep 10 13:19:13.950 [Notice] Bootstrapped 72%: Loading relay descriptors.
Sep 10 13:19:13.950 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 460/2364 usable descriptors.
Sep 10 13:19:14.192 [Notice] Bootstrapped 77%: Loading relay descriptors.
Sep 10 13:19:14.192 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 552/2364 usable descriptors.
Sep 10 13:19:14.618 [Notice] We now have enough directory information to build circuits.
Sep 10 13:19:14.618 [Notice] Bootstrapped 80%: Connecting to the Tor network.
Sep 10 13:19:14.618 [Notice] Bootstrapped 85%: Finishing handshake with first hop.
Sep 10 13:19:14.840 [Notice] Bootstrapped 90%: Establishing a Tor circuit.
Sep 10 13:19:16.475 [Notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Sep 10 13:19:16.475 [Notice] Bootstrapped 100%: Done.

Child Tickets

Change History (1)

comment:1 Changed 8 years ago by rransom

Resolution: duplicate
Status: newclosed

Duplicate of #3952.

Note: See TracTickets for help on using tickets.