Opened 8 years ago

Closed 8 years ago

Last modified 22 months ago

#3991 closed enhancement (not a bug)

REQ: Google Analytics filter/block

Reported by: joyton Owned by: mikeperry
Priority: Medium Milestone:
Component: Firefox Patch Issues Version:
Severity: Normal Keywords:
Cc: jcrimby@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I was not sure where to place this request, whether Tor Browser or TorBrowserButton would be best. BTW, considering Tor Browser has been known as Tor Browser Bundle (TBB) for a long time, does it not seem a bit confusing to now call TorButton, Tor Browser Button (TBB)?

Currently the easiest way to prevent Google Analytics (GA) tracking from within Firefox is by using the NoScript Surrogate Scripts (SS) feature, as far as I understand. However, SS is only functional on pages and sites where JS is blocked. One will see a Google Analytics entry in the NoScriopt taskbar flyout. That means TBB does not use NoScript SS, and thus does not block Google Analytics tracking (AFAIK), because TBB ships NoScipt to globally allow JS by default.

The more cumbersome (and less elegant?) solution seems to be using AdBlock Plus (with EasyList) and Greasemonkey (with custom script). I use this solution for TBB when I allows JS via. NoScript. This solution seems to work well, however, it may still break a few obscure video sites that use GA atypically. There is an easy solution for sites that do break: simply whitelist the sites via. ABP (with Easylist) and Greasemonkey script.

The "solution" offered by Google, their opt-out add-on, is no solution at all (big surprise there!).

I do realise Tor Project is heading toward anonymity by design for Tor Browser, and in doing so I hope a solution can found for GA so one doesn't need to rely on add-ons (besides maybe Tor Browser Button). Unless there is a solution already in the works?

Please feel free to tell me I'm wrong, if I am. Thanks.

Child Tickets

Change History (5)

comment:1 Changed 8 years ago by joyton

Note:

Using NoScript SS can break some sites that use GA atypically, unless SS is allowed via. NoScript. Likewise, using AdBlock Plus and Greasemonkey breaks can break some sites that use GA atypically, unless the site is whitelisted.

comment:2 Changed 8 years ago by mikeperry

Yep, so we're already seeing the NoScript guy fight an arms race for Google Analytics similar to the one I talked about for "Web Bugs" at https://trac.torproject.org/projects/tor/ticket/3975#comment:1. At first it was harmless to just block, but then sites wanted to integrate their own scripts with it for measurement purposes, so he had to implement placeholders, compatibility hooks, surrogate scripts, etc etc etc.

And then, even if you win this arms race against Google Analytics, you lose it against any of the other several dozen (hundreds?) of DoubleClick subsidiary domains and data exchange partnerships.

Therefore, our approach right now is to disable third party cookies and any other way that Google Analytics has of telling you are the same person on both twitter and gmail: https://blog.torproject.org/blog/improving-private-browsing-modes-do-not-track-vs-real-privacy-design

We feel that there is nothing technology can do to stop twitter from selling Google (or anyone else) the fact that a certain twitter account exists and when how it is used and even what IPs might use it. We can prevent Google from being able to tell that the same person who has this twitter account also has a gmail account, a facebook account, etc etc etc.

In short, we want to solve this problem at the source rather than though an arms race of filtering technologies.

comment:3 Changed 8 years ago by mikeperry

Resolution: not a bug
Status: newclosed

comment:4 Changed 22 months ago by cypherpunks

Severity: Blocker

Duplicate: #17569, if this waste of bytes is blocked then that's 35.1 KB of useless garbage saved per each request ✌️😉

comment:5 Changed 22 months ago by cypherpunks

Severity: BlockerNormal
Note: See TracTickets for help on using tickets.