Opened 8 years ago

Closed 8 years ago

#3997 closed defect (not a bug)

Problems with twitter

Reported by: 7__r Owned by: mikeperry
Priority: Medium Milestone: TorBrowserBundle 2.2.x-stable
Component: TorBrowserButton Version: Torbutton: 1.4.0
Severity: Keywords: MikePerryIterationFires20110925
Cc: erinn, tor-qa, phobos, ioerror, nickm, runa Actual Points: 1
Parent ID: Points: 1
Reviewer: Sponsor:

Description

I'm experiencing some issues w/ twitter. I use Tor Bundle 2.2.32-4, the latest one on the blog, on Ubunut and I couldn't access twitter two days ago and still. The problem is sometimes it give me just a white blank page, after retrying for manytimes, it might open the home page but I can't tweet anything, and the timeline don't get updated at all. I can't access my mentions or any other things on twitter. On the right panel, there are no pictures of my followers of people I'm following and the trends don't appear too. Just for note: I use Tor Bundle for Windows and the same problem there, and I can access my account from HootSuite client without any problems. If you didn't understand the problem I would upload pictures of it. Forgive my English and forgive me for any mistakes b/c this is my first time. Thank you for what are you doing here.

Child Tickets

Change History (26)

comment:1 Changed 8 years ago by 7__r

Component: - Select a componentTorBrowserButton
Owner: set to mikeperry

comment:2 Changed 8 years ago by mikeperry

Cc: erinn nickm phobos tor-qa added

Can someone with a twitter account verify this? Don't gots me one of those.

Twitter works w/o login for me.

comment:3 Changed 8 years ago by mikeperry

(By admitting I don't have a twitter account, did I just damage my anonymity set, or exonerate myself? We'll never now.)

Also: Cc tor-qa.

kthxby

comment:4 Changed 8 years ago by mikeperry

Cc: arma runa ioerror added

Do u guys hav twitter accounts??

We might not be able to fix this. I think the comodohacker might have done it. Five alarm fire.

comment:5 Changed 8 years ago by mikeperry

Cc: StrangeCharm added

Wow, tor-qa replied. Not bad for not existing (thank StrangeCharm).

Verdict is https-everywhere might be the culprit, but also might not be.

Also, nobody appears to actually use TBB.

News at 11 (I won't be awake at that hour).

comment:6 Changed 8 years ago by erinn

I use TBB and twitter and yeah, it is kind of broken this time. The auto-update part works for me, and scrolling down the page will 'refresh' the tweets and show me old ones. But going to a new page (e.g., someone's twitter page) will behave randomly: sometimes I get a white page, sometimes I get their actual page but some elements are missing, like the follow button, sometimes I have to reload it before I can get the entire page as it should be. Testing it some more (looking at my followers, who I'm following), it will load parts of the page, but just spin on the section that would actually list all of the people.

I'm not sure how to diagnose what's going on. But it involves whatever you changed to make the auto-scrolling happen.

comment:7 Changed 8 years ago by erinn

Milestone: Tor Browser Bundle for LinuxTorBrowserBundle 2.2.x-stable
Version: Tor: 0.2.3.3-alphaTorbutton: 1.4

comment:8 Changed 8 years ago by 7__r

I don't think https-everywhere is culprit, because I tried to disable it with no-script and the same problem happened. The login screen works fine with me too but the problems start when I log in. And yes, I think it's kind of difficult to describe this bug and particularity if you don't have twitter account.

comment:9 Changed 8 years ago by 7__r

I found a solution. I downloaded the Vidalia Bundle (the latest version with TorButton 1.4.3) and used it with polipo. I used the 172.0.0.1:9050 proxy for http and ssl. check.torproject.org gives me "Congratulations" and Test Sittings in TorButton preferences gives me the same. I can access twitter as usual and even with the auto-scroll, but the problem is there is no certificate for the website. Firefox says "This site does not supply identity information. Your connection to this site is only partially encrypted and does not prevent eavesdropping". This problem is only with twitter and even though I disabled HTTPS-Everywhere extension.
So maybe the main problem is with twitter certificate or some other problem happened when the developers fixed the auto-scroll bug.
I want to know if this solution works and if it safe. I live in Syria and you probably know what's going on here. If they (security) caught me I could return home a dead body.

comment:10 Changed 8 years ago by 7__r

I'm sorry, the proxy I used is 127.0.0.1:8118. Sorry about that.

comment:11 Changed 8 years ago by mikeperry

7r: I am definitely taking this seriously. I am just a bit frustrated that we did not seem notice this in-house, given the number of active twitter users we have here (barring myself, of course). That's what the earlier noise was about.

Erinn and I are diagnosing it now, though.

comment:12 Changed 8 years ago by mikeperry

Cc: nickm phobos arma runa ioerror StrangeCharm removed
Keywords: MikePerryIterationFires20110925 added; Twitter removed

I'll spare the rest of you folks any more noise, since a fix/workaround obviously does not apply to you...

comment:13 Changed 8 years ago by mikeperry

Summary: Problems with twitterProblems with twitter and large HTTP pipelines

Ok, 7r: our current believe is that this is related to pipelining in TBB. I personally find this odd, because polipo also does pipelining... But we seem to at least worked around the bug by disabling pipelining at the about:config url window, but our efforts are currently complicated due to what appears to be heavy load at the moment.

Are you willing to do some TBB testing? Can you try different values of the about:config setting 'network.http.pipelining.maxrequests'? Try to range it from 1 to 8 and see which, if any, settings work without issue?

comment:14 Changed 8 years ago by 7__r

If it safe, I will do it. But please, give me more directions and do you want me to test it on Tor Browser Bundle or Vidalia Bundle with polipo?

comment:15 in reply to:  14 Changed 8 years ago by mikeperry

Replying to 7__r:

If it safe, I will do it. But please, give me more directions and do you want me to test it on Tor Browser Bundle or Vidalia Bundle with polipo?

Hold on. We've just discovered that there is *also* an interaction with HTTPS-Everywhere for certain pipeline values. This one is going to be messy. Perhaps we should just leave you out of it.

The safest option should be to continue using TBB, but to disable pipelining in about:config. There should be three values to set to false at the url 'about:config': network.http.pipelining, network.http.pipelining.ssl, and network.http.proxy.pipelining. Set those all to false, and TBB should work with twitter again.

We recommend you leave HTTPS-Everywhere enabled.

comment:16 Changed 8 years ago by 7__r

It didn't work with me, I set all these values to false and tried many values for 'network.http.pipelining.maxrequests' and nothing happened. I even tried to use twitter without https mode. I disabled it from setting and disabled all HTTPS-Everywhere rules and the same problem, just a blank white screen.

comment:17 Changed 8 years ago by 7__r

BTW, before it gives me a white page, firefox froze for around 10 seconds with 'not responding' on title, then it gives me a white blank page.

comment:18 Changed 8 years ago by mikeperry

Hrmm.. Given that your report directly conflicts Erinn's on every detail, I think the only conclusion we can come to is that the bug is either crazy non-deterministic, or it does not in fact have anything to do with pipelining, but instead something else entirely.

Have you been using the TBBs for long? When did this first become an issue for you? What was the last known-good TBB you used?

comment:19 Changed 8 years ago by 7__r

Yes, I'm using Tor Bundle for Windows and Linus for around six monthes (since the revolution in my country started) and the first time I had this problem was two days ago. Yesterday, I could barley connect to Tor, and when I could connect, check.torproject.org gives me error 'We have temporally outage of service and we can't determine if your are using Tor' even though the ip it gave me wasn't my home-ip.
And after more retrys, I can now access twitter on http w/o ssl encryption.

comment:20 Changed 8 years ago by mikeperry

Yeah, I suspect you're seeing several different errors at once here and confusing them. Check failed independently due to an upgrade issue on our end that should now be fixed (I hope). Tor may be slow because of overload at your bridge.

We recommend not disabling ssl encryption for twitter, though it is likely not life-threatening to do so.. However, it is possible that this is a twitter problem, and unrelated to our changes at all. These conflicting reports make it quite weird.

Do you have a list of download history of your TBB downloads that you used before twitter stopped working? Do you know if this one worked: https://blog.torproject.org/blog/new-tor-browser-bundles-5

I ask this question because we're going to need to try some regression testing over here to absolutely make sure it wasn't a recent TBB release that caused your problem.

comment:21 Changed 8 years ago by 7__r

Yes, I used Tor Bundle since this one https://blog.torproject.org/blog/new-tor-browser-bundles-1 before that, I was using the stable Tor Bundle with firefox 3.6. I had no problem with any bundle before. About this one https://blog.torproject.org/blog/new-tor-browser-bundles-5, yes I used it and it was working fine.

comment:22 Changed 8 years ago by mikeperry

Summary: Problems with twitter and large HTTP pipelinesProblems with twitter

Erinn also says that she tested Torbutton 1.4.2 on TBB 2.2.32-4 and it works. However, 7r also reported that 1.4.3 works on vanilla Firefox..

I am very confused.

comment:23 Changed 8 years ago by 7__r

It may sound crazy, but it's working now. The only changes I made is I set network.http.pipelining.maxrequests to 4 and network.http.pipelining, network.http.pipelining.ssl, and network.http.proxy.pipelining to false. This solution didn't work yesterday, but it's working now. So maybe Tor has nothing to do with this problem, it's maybe from twitter.

comment:24 in reply to:  23 ; Changed 8 years ago by mikeperry

Cc: phobos ioerror nickm runa added

Replying to 7__r:

It may sound crazy, but it's working now. The only changes I made is I set network.http.pipelining.maxrequests to 4 and network.http.pipelining, network.http.pipelining.ssl, and network.http.proxy.pipelining to false. This solution didn't work yesterday, but it's working now. So maybe Tor has nothing to do with this problem, it's maybe from twitter.

Please keep us updated. Right now, I am inclined to believe that your changes are just coinciding with arbitrary twitter hiccups and there probably isn't a bug on our side here.

To the Cc'd: Back on you go! Let us know if you have any twitter problems with the TBBs.

comment:25 in reply to:  24 Changed 8 years ago by runa

Replying to mikeperry:

Replying to 7__r:

It may sound crazy, but it's working now. The only changes I made is I set network.http.pipelining.maxrequests to 4 and network.http.pipelining, network.http.pipelining.ssl, and network.http.proxy.pipelining to false. This solution didn't work yesterday, but it's working now. So maybe Tor has nothing to do with this problem, it's maybe from twitter.

Please keep us updated. Right now, I am inclined to believe that your changes are just coinciding with arbitrary twitter hiccups and there probably isn't a bug on our side here.

To the Cc'd: Back on you go! Let us know if you have any twitter problems with the TBBs.

Works like a charm.

comment:26 Changed 8 years ago by mikeperry

Actual Points: 1
Points: 1
Resolution: not a bug
Status: newclosed

I am going to close this then on the assumption it was transient twitter failures.

Note: See TracTickets for help on using tickets.